summaryrefslogtreecommitdiff
path: root/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt')
-rw-r--r--ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt b/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
index 0c4f5df..d3bb616 100644
--- a/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
+++ b/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
@@ -22,14 +22,14 @@ project (simple-weston-client)
find_package(PkgConfig)
pkg_check_modules(WAYLAND_CLIENT wayland-client REQUIRED)
pkg_check_modules(WAYLAND_CURSOR wayland-cursor REQUIRED)
-pkg_check_modules(LIBWESTON_PROTOCOLS libweston-6-protocols QUIET)
+pkg_check_modules(LIBWESTON_PROTOCOLS libweston-8-protocols QUIET)
if(${LIBWESTON_PROTOCOLS_FOUND})
#check for DLT
pkg_check_modules(DLT automotive-dlt QUIET)
#import the pkgdatadir from libweston-protocols pkgconfig file
- execute_process(COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=pkgdatadir libweston-6-protocols
+ execute_process(COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=pkgdatadir libweston-8-protocols
OUTPUT_VARIABLE WestonProtocols_PKGDATADIR)
string(REGEX REPLACE "[\r\n]" "" WestonProtocols_PKGDATADIR "${WestonProtocols_PKGDATADIR}")
SET(LIBWESTON_PROTOCOLS_PKGDATADIR ${WestonProtocols_PKGDATADIR})
@@ -80,10 +80,10 @@ if(${LIBWESTON_PROTOCOLS_FOUND})
endif(${LIBWESTON_PROTOCOLS_FOUND})
include_directories(
- ${WAYLAND_CLIENT_INCLUDE_DIR}
- ${WAYLAND_CURSOR_INCLUDE_DIR}
+ ${WAYLAND_CLIENT_INCLUDE_DIRS}
+ ${WAYLAND_CURSOR_INCLUDE_DIRS}
${CMAKE_CURRENT_BINARY_DIR}
- ${DLT_INCLUDE_DIR}
+ ${DLT_INCLUDE_DIRS}
)
link_directories(