summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9e492f43b..d907468cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2584,8 +2584,13 @@ AC_ARG_WITH([extract-dir],
AC_HELP_STRING([--with-extract-dir=EXTRACT_DIR]),
[
EXTRACT_DIR="$withval"
- AS_IF([test ! -e $EXTRACT_DIR], AC_MSG_ERROR([EXTRACT_DIR does not exist: $EXTRACT_DIR]))
- PS_DEVS="$PS_DEVS docxwrite"
+ AS_IF([test x"$EXTRACT_DIR" != x"no"],
+ [AS_IF([test -e $EXTRACT_DIR],[ PS_DEVS="$PS_DEVS docxwrite"] ,AC_MSG_ERROR([EXTRACT_DIR does not exist: $EXTRACT_DIR]))])
+ ],
+ [
+ AC_MSG_CHECKING([Checking for "extract" in default location])
+ EXTRACT_DIR="extract"
+ AS_IF([test -e $EXTRACT_DIR], [AC_MSG_RESULT(yes); PS_DEVS="$PS_DEVS docxwrite"], [EXTRACT_DIR=""; AC_MSG_RESULT(no)])
]
)