summaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorPetr Baudis <pasky@suse.cz>2006-06-24 18:35:12 -0700
committerJunio C Hamano <junkio@cox.net>2006-07-02 17:14:42 -0700
commitd595a473ee628d0f88989d06871d9752caafa7e9 (patch)
treee06418029e09256d4e82c8d6bf0a41357cf9b1ac /perl/Makefile.PL
parent523bbaa4580a103b0994b5e3c71efcb1a8c6a7db (diff)
downloadgit-d595a473ee628d0f88989d06871d9752caafa7e9.tar.gz
Git.pm: assorted build related fixes.
- We passed our own *.a archives as LIBS to the submake that runs in perl/; separate LIBS and EXTLIBS and pass the latter which tells what the system libraries are used. - The quoting of preprocesor symbol definitions passed down to perl/ submake was loose and we lost double quotes around include directives. Use *_SQ to quote them properly. - The installation location of perl/ submake is not architecture neutral anymore, so use SITEARCH instead of SITELIB. Signed-off-by: Petr Baudis <pasky@suse.cz> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 54e8b20ed8..92c140d39b 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -3,7 +3,7 @@ use ExtUtils::MakeMaker;
sub MY::postamble {
return <<'MAKE_FRAG';
instlibdir:
- @echo $(INSTALLSITELIB)
+ @echo $(INSTALLSITEARCH)
MAKE_FRAG
}