summaryrefslogtreecommitdiff
path: root/spec/fixtures/packages/conan
diff options
context:
space:
mode:
authorGitLab Bot <gitlab-bot@gitlab.com>2020-06-18 11:18:50 +0000
committerGitLab Bot <gitlab-bot@gitlab.com>2020-06-18 11:18:50 +0000
commit8c7f4e9d5f36cff46365a7f8c4b9c21578c1e781 (patch)
treea77e7fe7a93de11213032ed4ab1f33a3db51b738 /spec/fixtures/packages/conan
parent00b35af3db1abfe813a778f643dad221aad51fca (diff)
downloadgitlab-ce-8c7f4e9d5f36cff46365a7f8c4b9c21578c1e781.tar.gz
Add latest changes from gitlab-org/gitlab@13-1-stable-ee
Diffstat (limited to 'spec/fixtures/packages/conan')
-rw-r--r--spec/fixtures/packages/conan/package_files/conan_package.tgzbin0 -> 2125 bytes
-rw-r--r--spec/fixtures/packages/conan/package_files/conaninfo.txt33
-rw-r--r--spec/fixtures/packages/conan/package_files/conanmanifest.txt4
-rw-r--r--spec/fixtures/packages/conan/recipe_files/conanfile.py47
-rw-r--r--spec/fixtures/packages/conan/recipe_files/conanmanifest.txt2
5 files changed, 86 insertions, 0 deletions
diff --git a/spec/fixtures/packages/conan/package_files/conan_package.tgz b/spec/fixtures/packages/conan/package_files/conan_package.tgz
new file mode 100644
index 00000000000..6163364f3f9
--- /dev/null
+++ b/spec/fixtures/packages/conan/package_files/conan_package.tgz
Binary files differ
diff --git a/spec/fixtures/packages/conan/package_files/conaninfo.txt b/spec/fixtures/packages/conan/package_files/conaninfo.txt
new file mode 100644
index 00000000000..2a02515a19b
--- /dev/null
+++ b/spec/fixtures/packages/conan/package_files/conaninfo.txt
@@ -0,0 +1,33 @@
+[settings]
+ arch=x86_64
+ build_type=Release
+ compiler=apple-clang
+ compiler.libcxx=libc++
+ compiler.version=10.0
+ os=Macos
+
+[requires]
+
+
+[options]
+ shared=False
+
+[full_settings]
+ arch=x86_64
+ build_type=Release
+ compiler=apple-clang
+ compiler.libcxx=libc++
+ compiler.version=10.0
+ os=Macos
+
+[full_requires]
+
+
+[full_options]
+ shared=False
+
+[recipe_hash]
+ b4b91125b36b40a7076a98310588f820
+
+[env]
+
diff --git a/spec/fixtures/packages/conan/package_files/conanmanifest.txt b/spec/fixtures/packages/conan/package_files/conanmanifest.txt
new file mode 100644
index 00000000000..bc34b81b050
--- /dev/null
+++ b/spec/fixtures/packages/conan/package_files/conanmanifest.txt
@@ -0,0 +1,4 @@
+1565723794
+conaninfo.txt: 2774ebe649804c1cd9430f26ab0ead14
+include/hello.h: 8727846905bd09baecf8bdc1edb1f46e
+lib/libhello.a: 7f2aaa8b6f3bc316bba59e47b6a0bd43
diff --git a/spec/fixtures/packages/conan/recipe_files/conanfile.py b/spec/fixtures/packages/conan/recipe_files/conanfile.py
new file mode 100644
index 00000000000..910bd5a0b51
--- /dev/null
+++ b/spec/fixtures/packages/conan/recipe_files/conanfile.py
@@ -0,0 +1,47 @@
+from conans import ConanFile, CMake, tools
+
+
+class HelloConan(ConanFile):
+ name = "Hello"
+ version = "0.1"
+ license = "<Put the package license here>"
+ author = "<Put your name here> <And your email here>"
+ url = "<Package recipe repository url here, for issues about the package>"
+ description = "<Description of Hello here>"
+ topics = ("<Put some tag here>", "<here>", "<and here>")
+ settings = "os", "compiler", "build_type", "arch"
+ options = {"shared": [True, False]}
+ default_options = "shared=False"
+ generators = "cmake"
+
+ def source(self):
+ self.run("git clone https://github.com/conan-io/hello.git")
+ # This small hack might be useful to guarantee proper /MT /MD linkage
+ # in MSVC if the packaged project doesn't have variables to set it
+ # properly
+ tools.replace_in_file("hello/CMakeLists.txt", "PROJECT(HelloWorld)",
+ '''PROJECT(HelloWorld)
+include(${CMAKE_BINARY_DIR}/conanbuildinfo.cmake)
+conan_basic_setup()''')
+
+ def build(self):
+ cmake = CMake(self)
+ cmake.configure(source_folder="hello")
+ cmake.build()
+
+ # Explicit way:
+ # self.run('cmake %s/hello %s'
+ # % (self.source_folder, cmake.command_line))
+ # self.run("cmake --build . %s" % cmake.build_config)
+
+ def package(self):
+ self.copy("*.h", dst="include", src="hello")
+ self.copy("*hello.lib", dst="lib", keep_path=False)
+ self.copy("*.dll", dst="bin", keep_path=False)
+ self.copy("*.so", dst="lib", keep_path=False)
+ self.copy("*.dylib", dst="lib", keep_path=False)
+ self.copy("*.a", dst="lib", keep_path=False)
+
+ def package_info(self):
+ self.cpp_info.libs = ["hello"]
+
diff --git a/spec/fixtures/packages/conan/recipe_files/conanmanifest.txt b/spec/fixtures/packages/conan/recipe_files/conanmanifest.txt
new file mode 100644
index 00000000000..432b12f39fa
--- /dev/null
+++ b/spec/fixtures/packages/conan/recipe_files/conanmanifest.txt
@@ -0,0 +1,2 @@
+1565723790
+conanfile.py: 7c042b95312cc4c4ee89199dc51aebf9