summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoaquín Cuenca Abela <cuenca@src.gnome.org>2003-10-04 10:36:31 +0000
committerJoaquín Cuenca Abela <cuenca@src.gnome.org>2003-10-04 10:36:31 +0000
commit7342e79cff5c6885bd41773a4107e7924f732c0a (patch)
tree63d3aebd9ae9ff1a887625c71f86eac2a3d9eef8 /configure.in
parent8f8dd5f0d7cefe89ef8a05a15f5446f07703cd16 (diff)
downloadglade-7342e79cff5c6885bd41773a4107e7924f732c0a.tar.gz
read the name of the plugin to be used by each catalog and pass it to the
* src/glade-catalog.c: read the name of the plugin to be used by each catalog and pass it to the constructor of glade-widget-class. Also if a specific class has a specific plugin name to be used, use it instead of the generic of the whole catalog. * src/glade-gtk.c: remove the "static" from the functions that should be exported, and remove the "temp hack" that was used to load the address of the functions, as it's no more needed. * src/glade-property-class.c: remove glade_property_class_get_{get,set}_function and use g_module_symbol instead. * src/glade-widget-class.c: use g_module_symbol instead of the previous {get,set} functions. Remove unused functions. Rename glade_widget_class_new_from_name2 to glade_widget_class_new as it's the only constructor. Use the plugin name that glade-widget-class passed to the constructor and load it. * src/glade-widget-class.h: add a GModule* by GladeWidgetClass. * src/glade-widget.c: remove the #include <glade-gtk.h> * widgets/gtk-additional.xml: add the name of the plugin ("gtk") for all the widgets on gtk-additional. * widgets/gtk-base.xml: ditto * widgets/gtkwidget.xml: remove the "name" tag, as it's not need. * widgets/gtkwindow.xml: change glade_gtk_widget_{get,set}_tooltip by "ignore", as that's what these functions do.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9444531a..7762b8b2 100644
--- a/configure.in
+++ b/configure.in
@@ -12,13 +12,14 @@ AC_PROG_INTLTOOL([0.11])
GNOME_COMMON_INIT
GNOME_PLATFORM_GNOME_2(yes, force)
-AM_PROG_LIBTOOL
-
AC_ISC_POSIX
AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_MAKE_SET
+AC_LIBTOOL_DLOPEN
+AC_PROG_LIBTOOL
+
AC_CHECK_HEADERS(os2.h)
dnl ================================================================
@@ -77,9 +78,19 @@ else
catalogsdir="${prefix}/${DATADIRNAME}/${PACKAGE}-${VERSION}/catalogs"
fi
+dnl ================================================================
+dnl MODULES
+dnl ================================================================
+if test "x${libdir}" = "xNONE"; then
+ modulesdir="${ac_default_libdir}/${PACKAGE}"
+else
+ modulesdir="${libdir}/${PACKAGE}"
+fi
+
AC_SUBST(pixmapsdir)
AC_SUBST(widgetsdir)
AC_SUBST(catalogsdir)
+AC_SUBST(modulesdir)
AC_OUTPUT([
Makefile