summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTristan Van Berkom <tvb@src.gnome.org>2006-07-06 18:48:39 +0000
committerTristan Van Berkom <tvb@src.gnome.org>2006-07-06 18:48:39 +0000
commitddeae654c8b2bb6b3b158b2a1f3fb37fdfe0560e (patch)
tree447208c3ba2e738d9830f5374b5c5b0e050a6e97 /configure.in
parentc9197e463216f41ac21927a42e0d30116446fbe8 (diff)
downloadglade-ddeae654c8b2bb6b3b158b2a1f3fb37fdfe0560e.tar.gz
Check for --disable-gnome arg.
* configure.in: Check for --disable-gnome arg.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 0fae1c80..904289fe 100644
--- a/configure.in
+++ b/configure.in
@@ -62,10 +62,19 @@ AC_SUBST(GTK_CFLAGS)
dnl ================================================================
dnl Check for optional gnome libs
dnl ================================================================
-PKG_CHECK_MODULES(GNOME, libbonoboui-2.0 libgnomeui-2.0,
- [have_gnome=yes],[have_gnome=no])
-AC_SUBST(GNOME_LIBS)
-AC_SUBST(GNOME_CFLAGS)
+AC_ARG_ENABLE(gnome,
+[ --disable-gnome disable gnome catalog],
+ check_gnome=$enableval, check_gnome=yes)
+
+if test x"$check_gnome" = x"yes"; then
+ PKG_CHECK_MODULES(GNOME, libbonoboui-2.0 libgnomeui-2.0,
+ [have_gnome=yes],[have_gnome=no])
+ AC_SUBST(GNOME_LIBS)
+ AC_SUBST(GNOME_CFLAGS)
+else
+ have_gnome=no
+fi
+
AM_CONDITIONAL(BUILD_GNOME, test x"$have_gnome" = "xyes")
dnl ================================================================