summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJoaquin Cuenca Abela <e98cuenc@yahoo.com>2004-03-09 21:17:33 +0000
committerJoaquĆ­n Cuenca Abela <cuenca@src.gnome.org>2004-03-09 21:17:33 +0000
commit2a7f287d383be48fcb52c94211fcd19b523ddfc1 (patch)
tree4913aecce6133b6782435171be410d8c195e05f0 /src/Makefile.am
parente24a0efdc79c6dfc60ecc6164e49939db59831c5 (diff)
downloadglade-2a7f287d383be48fcb52c94211fcd19b523ddfc1.tar.gz
write properties that have a default value of NULL. micro-manage the new
2004-03-09 Joaquin Cuenca Abela <e98cuenc@yahoo.com> * src/glade-property.c (glade_property_write): write properties that have a default value of NULL. * src/glade-project.c: micro-manage the new names of widgets. As soon as a new slot is available (for instance, if you change the name of button3, then button3 becomes available) its used for a new widget. * src/glade-project.c (glade_project_dispose, glade_project_finalize): implement dispose and finalize methods for GladeProject. * src/glade-id-allocator.[ch]: code to manage the ids availables for widgets. Code from Owen Taylor.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f6a88cba..0b458d91 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -54,7 +54,8 @@ glade_3_SOURCES = \
glade-command.c \
glade-menu-editor.c \
glade-keys-dialog.c \
- glade-transform.c
+ glade-transform.c \
+ glade-id-allocator.c
noinst_HEADERS = \
glade.h \
@@ -84,4 +85,5 @@ noinst_HEADERS = \
glade-command.h \
glade-menu-editor.h \
glade-keys-dialog.h \
- glade-transform.h
+ glade-transform.h \
+ glade-id-allocator.h