summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2016-10-30 20:38:57 -0700
committerPhilip Withnall <philip.withnall@collabora.co.uk>2016-11-23 10:45:56 +0000
commita24f57b071758b01500e2b4b9c05d2a60f8280bf (patch)
tree0a2becd636aa1fb9f854fd569ce1236420aef68b /Makefile.am
parent673036d609b2c87abdef9149a2edfedb4861e65e (diff)
downloadglib-a24f57b071758b01500e2b4b9c05d2a60f8280bf.tar.gz
glib: Add installed Valgrind suppressions file for GLib and GIO
While we cannot get Valgrind to automatically load this suppression file for applications which link to GLib (https://bugs.kde.org/show_bug.cgi?id=160905), we can at least install it on systems in a shared directory, so that developers can use a standardised (and up-to-date) suppressions file for GLib, rather than rolling their own. The file will typically be installed to: /usr/share/glib-2.0/valgrind/glib.supp Distributors: it is recommended that this suppression file be installed as part of the development package for GLib in your distribution. https://bugzilla.gnome.org/show_bug.cgi?id=666114
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a1c9c33a0..54f22ee6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,6 +103,10 @@ endif
$(pkgconfig_DATA): config.status
+# Install Valgrind suppression file
+valgrinddir = $(datadir)/glib-2.0/valgrind
+dist_valgrind_DATA = glib.supp
+
# build documentation when doing distcheck
DISTCHECK_CONFIGURE_FLAGS = --enable-debug --enable-gtk-doc --enable-man --disable-maintainer-mode