summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <withnall@endlessm.com>2018-02-26 11:55:03 +0000
committerPhilip Withnall <withnall@endlessm.com>2018-04-18 15:13:02 +0100
commit723ac89b0caee620e5f0cae279f429fc514478c8 (patch)
tree7d6c934eb8cb639736511700b36e2dcca7ab4e2a /configure.ac
parent3e4e005c96dda19e59355cdb0a8701cca7b46cad (diff)
downloadglib-723ac89b0caee620e5f0cae279f429fc514478c8.tar.gz
tests: Add a GFileMonitor test for G_FILE_MONITOR_WATCH_HARD_LINKS
Add a test for monitoring an existing local file, with the WATCH_HARD_LINKS flag specified. This would previously cause a crash; now it doesn’t. This test contains a FIXME where I suspect we should be getting some additional file change notifications from changes made through the hard link; this requires further follow up and probably further fixes to our inotify backend. Signed-off-by: Philip Withnall <withnall@endlessm.com> https://bugzilla.gnome.org/show_bug.cgi?id=755721
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 06397b150..44c5ada59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -874,7 +874,7 @@ int main ()
AC_MSG_RESULT($glib_ssize_type)
# Check for some functions
-AC_CHECK_FUNCS(lstat strsignal vsnprintf stpcpy strcasecmp strncasecmp poll vasprintf setenv unsetenv getc_unlocked readlink symlink fdwalk mkostemp)
+AC_CHECK_FUNCS(lstat strsignal vsnprintf stpcpy strcasecmp strncasecmp poll vasprintf setenv unsetenv getc_unlocked readlink symlink fdwalk mkostemp link)
AC_CHECK_FUNCS(lchmod lchown fchmod fchown utimes getresuid)
AC_CHECK_FUNCS(getmntent_r setmntent endmntent hasmntopt getfsstat getvfsstat fallocate)
case $host_os in aix*) ac_cv_func_splice=no ;; esac # AIX splice() is something else