summaryrefslogtreecommitdiff
path: root/gio/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-01-19 15:52:15 +0400
committerMarc-André Lureau <marcandre.lureau@redhat.com>2022-01-26 18:19:44 +0400
commit83d45c4f35dc87ba71145283b88b00cd3f44caba (patch)
tree58dabff6ebc3a71503a23a4a70ee1cc4be991029 /gio/meson.build
parentaf1777d3d3d77682ccb218eec7efb46a1d0776e0 (diff)
downloadglib-83d45c4f35dc87ba71145283b88b00cd3f44caba.tar.gz
gio: compile GUnixConnection on all platforms
On !UNIX, return an error for send_fd() & receive_fd(). (the unixfdmessage unit is not compiled on !UNIX) The header is installed under the common GIO include directory. Ensure G_TYPE_UNIX_CONNECTION is registered on all platforms. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Diffstat (limited to 'gio/meson.build')
-rw-r--r--gio/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/gio/meson.build b/gio/meson.build
index 9e7539edd..d6a3d2d76 100644
--- a/gio/meson.build
+++ b/gio/meson.build
@@ -346,7 +346,6 @@ if host_system != 'windows'
unix_sources = files(
'gfiledescriptorbased.c',
'giounix-private.c',
- 'gunixconnection.c',
'gunixfdlist.c',
'gunixfdmessage.c',
'gunixmount.c',
@@ -374,7 +373,6 @@ if host_system != 'windows'
gio_unix_include_headers = files(
'gfiledescriptorbased.h',
- 'gunixconnection.h',
'gunixmounts.h',
'gunixfdlist.h',
'gunixfdmessage.h',
@@ -565,6 +563,7 @@ gio_sources = files(
'gdtlsclientconnection.c',
'gdtlsserverconnection.c',
'gunionvolumemonitor.c',
+ 'gunixconnection.c',
'gunixcredentialsmessage.c',
'gunixsocketaddress.c',
'gvfs.c',
@@ -702,6 +701,7 @@ gio_headers = files(
'gdtlsconnection.h',
'gdtlsclientconnection.h',
'gdtlsserverconnection.h',
+ 'gunixconnection.h',
'gunixcredentialsmessage.h',
'gunixsocketaddress.h',
'gvfs.h',