summaryrefslogtreecommitdiff
path: root/gio/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <pwithnall@endlessos.org>2022-06-07 18:11:32 +0100
committerPhilip Withnall <pwithnall@endlessos.org>2022-06-16 10:12:07 +0100
commitb3f49d08a627633d266f31187bff4cce869772d6 (patch)
tree817a0cc056d6cdb87e4c3789dccdc7be2972c5b4 /gio/meson.build
parentd7c3b0fbf2889d4afd04477b3fd2b8d3e7e00378 (diff)
downloadglib-b3f49d08a627633d266f31187bff4cce869772d6.tar.gz
build: Move gvdb to a subproject
Rather than carrying the copylib around inside GLib, which is a pain to synchronise and affects our code coverage statistics. This requires updating the CI images to cache the new subproject, including updating the `cache-subprojects.sh` script to pull in git submodules. It also requires adding `gioenumtypes_dep` to be added to the dependencies list of `libgio`, since it needs to be build before GVDB as it’s pulled in by the GIO headers which GVDB includes. Signed-off-by: Philip Withnall <pwithnall@endlessos.org> Helps: #2603
Diffstat (limited to 'gio/meson.build')
-rw-r--r--gio/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/gio/meson.build b/gio/meson.build
index 55bdaae93..d20d751b5 100644
--- a/gio/meson.build
+++ b/gio/meson.build
@@ -261,7 +261,6 @@ settings_headers = files(
)
settings_sources = files(
- 'gvdb/gvdb-reader.c',
'gdelayedsettingsbackend.c',
'gkeyfilesettingsbackend.c',
'gmemorysettingsbackend.c',
@@ -812,7 +811,8 @@ libgio = library('gio-2.0',
link_with: internal_deps,
dependencies : [libz_dep, libdl_dep, libmount_dep, libglib_dep,
libgobject_dep, libgmodule_dep, selinux_dep, xattr_dep,
- platform_deps, network_libs, libsysprof_capture_dep],
+ platform_deps, network_libs, libsysprof_capture_dep,
+ gioenumtypes_dep, gvdb_dep],
c_args : gio_c_args,
objc_args : gio_c_args,
# intl.lib is not compatible with SAFESEH
@@ -961,19 +961,19 @@ gio_querymodules = executable('gio-querymodules', 'gio-querymodules.c', 'giomodu
dependencies : [libgio_dep, libgobject_dep, libgmodule_dep, libglib_dep])
glib_compile_schemas = executable('glib-compile-schemas',
- ['gvdb/gvdb-builder.c', 'glib-compile-schemas.c'],
+ ['glib-compile-schemas.c'],
install : true,
# intl.lib is not compatible with SAFESEH
link_args : noseh_link_args,
- dependencies : [libgio_dep, libgobject_dep, libgmodule_dep, libglib_dep])
+ dependencies : [libgio_dep, libgobject_dep, libgmodule_dep, libglib_dep, gvdb_dep])
glib_compile_resources = executable('glib-compile-resources',
- [gconstructor_as_data_h, 'gvdb/gvdb-builder.c', 'glib-compile-resources.c'],
+ [gconstructor_as_data_h, 'glib-compile-resources.c'],
install : true,
c_args : gio_c_args,
# intl.lib is not compatible with SAFESEH
link_args : noseh_link_args,
- dependencies : [libgio_dep, libgobject_dep, libgmodule_dep, libglib_dep])
+ dependencies : [libgio_dep, libgobject_dep, libgmodule_dep, libglib_dep, gvdb_dep])
# Cannot override those programs in cross compilation case because they are
# native executables that cannot be run on the build machine.