summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2011-06-09 11:11:30 -0400
committerRyan Lortie <desrt@desrt.ca>2011-06-09 11:11:30 -0400
commit8f21e8145cf084ecd66c30cd868f56f7dcd87334 (patch)
tree4093c67299512f436220fcfc805906d36340d711 /gobject/Makefile.am
parent5794393c6fc6d63f4f1c9dd6fdd72946728f4246 (diff)
downloadglib-8f21e8145cf084ecd66c30cd868f56f7dcd87334.tar.gz
gobject: remove -DG_DISABLE_CONST_RETURNS
GObject had a few cases of depending on G_CONST_RETURN not being defined to 'const'. Remove those in preparation for deprecation of G_CONST_RETURN.
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 8c6da9b3b..5250548ea 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -18,8 +18,7 @@ AM_CPPFLAGS = \
$(GLIB_DEBUG_FLAGS) \
$(THREAD_FLAGS) \
-DG_DISABLE_DEPRECATED \
- -DGOBJECT_COMPILATION \
- -DG_DISABLE_CONST_RETURNS
+ -DGOBJECT_COMPILATION
gobject.def: gobject.symbols
$(AM_V_GEN) (echo -e EXPORTS; $(CPP) -P -DINCLUDE_VARIABLES -DINCLUDE_INTERNAL_SYMBOLS -DG_OS_WIN32 -DALL_FILES - <$(srcdir)/gobject.symbols | $(SED) -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g' | sort) > gobject.def