summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-01-12 21:28:23 +0100
committerAlexander Larsson <alexl@redhat.com>2010-01-12 21:37:50 +0100
commit94b8613b5ffefadb5c82424bd1f3083ff11fa811 (patch)
treefd14d8981fed01e7bfe77e8e0a8ec8fe8efeef51 /gobject/Makefile.am
parentde5c708e0b3d257388d3a5d09c80806d27069c88 (diff)
downloadglib-94b8613b5ffefadb5c82424bd1f3083ff11fa811.tar.gz
Use unconditional thread calls in gio and gobject
If threads are available we always enable threads in gobject, which means all gio/gobject code can enable the unconditional thread calls. This is a minor optimization since we avoid a bunch of unnecessary is-threads-enabled checks. https://bugzilla.gnome.org/show_bug.cgi?id=606775
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 98cece3f8..7579dc935 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -6,12 +6,17 @@ include $(top_srcdir)/Makefile.decl
SUBDIRS = . tests
+if HAVE_THREADS
+THREAD_FLAGS=-DG_THREADS_MANDATORY
+endif
+
AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"GLib-GObject\" \
-I$(top_srcdir) \
-I$(top_srcdir)/glib \
-I$(top_builddir) \
$(GLIB_DEBUG_FLAGS) \
+ $(THREAD_FLAGS) \
-DG_DISABLE_DEPRECATED \
-DGOBJECT_COMPILATION \
-DG_DISABLE_CONST_RETURNS