summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2008-07-27 15:54:15 +0000
committerTor Lillqvist <tml@src.gnome.org>2008-07-27 15:54:15 +0000
commita076a3045770456e6932d41eba97adf9b19b43f4 (patch)
tree35727ce8be92ef8e2f22d8123329e48cf22d9560 /gobject/Makefile.am
parent0a2cd70e5eb3ae8f1386fed43e9f0f3054ab9425 (diff)
downloadglib-a076a3045770456e6932d41eba97adf9b19b43f4.tar.gz
Set LIB_EXE_MACHINE_FLAG to either X86 or X64 on Windows. AC_SUBST it.
2008-07-27 Tor Lillqvist <tml@novell.com> * configure.in: Set LIB_EXE_MACHINE_FLAG to either X86 or X64 on Windows. AC_SUBST it. * */Makefile.am: Correspondingly, pass appropriate -machine flag to lib.exe when producing the import library for the MS toolchain. svn path=/trunk/; revision=7255
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 4d59fc035..f8a7de4c1 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -244,7 +244,7 @@ gobject-win32-res.o: gobject.rc
$(WINDRES) gobject.rc $@
gobject-2.0.lib: libgobject-2.0.la gobject.def
- lib -name:libgobject-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:gobject.def -out:$@
+ lib -machine:@LIB_EXE_MACHINE_FLAG@ -name:libgobject-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:gobject.def -out:$@
dist-hook: $(BUILT_EXTRA_DIST)
files='$(BUILT_EXTRA_DIST)'; \