summaryrefslogtreecommitdiff
path: root/gobject/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-03-07 11:13:24 +0000
committerMatthias Clasen <mclasen@redhat.com>2017-07-13 19:03:39 -0400
commit213957970ee4e58e37ee2c81766284af34dddcb9 (patch)
treecfc0a445c50052da61f0eaf90292275600fb1f26 /gobject/meson.build
parent98e641424b2e24cdae8c6e4ba022e53fc89d4640 (diff)
downloadglib-213957970ee4e58e37ee2c81766284af34dddcb9.tar.gz
meson: Fix glib, add gobject, gio, gthread, gmodule, etc
Several small fixes to the build files. Lots of tests have also been added, and glib tests pass now.
Diffstat (limited to 'gobject/meson.build')
-rw-r--r--gobject/meson.build65
1 files changed, 65 insertions, 0 deletions
diff --git a/gobject/meson.build b/gobject/meson.build
new file mode 100644
index 000000000..cdb644317
--- /dev/null
+++ b/gobject/meson.build
@@ -0,0 +1,65 @@
+#FIXME
+#if host_machine.system() == 'windows'
+# plat_src = []
+#else
+# plat_src = []
+#endif
+
+gobject_install_headers = [
+ 'gobject-autocleanups.h',
+ 'glib-types.h',
+ 'gbinding.h',
+ 'gboxed.h',
+ 'gclosure.h',
+ 'genums.h',
+ 'gmarshal.h',
+ 'gobject.h',
+ 'gparam.h',
+ 'gparamspecs.h',
+ 'gsignal.h',
+ 'gsourceclosure.h',
+ 'gtype.h',
+ 'gtypemodule.h',
+ 'gtypeplugin.h',
+ 'gvalue.h',
+ 'gvaluearray.h',
+ 'gvaluecollector.h',
+ 'gvaluetypes.h',
+ 'gobjectnotifyqueue.c', # sic
+]
+install_headers(gobject_install_headers, subdir : 'glib-2.0/gobject/')
+
+gobject_c_sources = [
+# 'gobject_probes.d',
+ 'gatomicarray.c',
+ 'gbinding.c',
+ 'gboxed.c',
+ 'gclosure.c',
+ 'genums.c',
+ 'gmarshal.c',
+ 'gobject.c',
+ 'gobject_trace.h',
+ 'gparam.c',
+ 'gparamspecs.c',
+ 'gsignal.c',
+ 'gsourceclosure.c',
+ 'gtype.c',
+ 'gtypemodule.c',
+ 'gtypeplugin.c',
+ 'gvalue.c',
+ 'gvaluearray.c',
+ 'gvaluetransform.c',
+ 'gvaluetypes.c',
+]
+
+libgobject = shared_library('gobject',
+sources : [ gobject_c_sources ],
+version : glib_version,
+soversion : interface_version,
+install : true,
+include_directories : inc_dirs,
+link_with : libglib,
+dependencies : libffi_dep,
+c_args : ['-DG_LOG_DOMAIN="GLib-GObject"', '-DGOBJECT_COMPILATION' ])
+
+subdir('tests')