summaryrefslogtreecommitdiff
path: root/gobject/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-11-02 10:03:22 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2017-11-02 10:03:22 +0530
commit625bfa0b36380b97205fa7df0e07f8eca13d616e (patch)
tree2dbe838c657391a85dc8fdadd87bc44a8257a2a0 /gobject/meson.build
parent430e2dd3f54734cfa87d6643f2370604abcf959d (diff)
downloadglib-625bfa0b36380b97205fa7df0e07f8eca13d616e.tar.gz
meson: Fix comment explaining gdb hacks
https://bugzilla.gnome.org/show_bug.cgi?id=788772
Diffstat (limited to 'gobject/meson.build')
-rw-r--r--gobject/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/gobject/meson.build b/gobject/meson.build
index 0c8c0cb26..dedc9fb60 100644
--- a/gobject/meson.build
+++ b/gobject/meson.build
@@ -100,9 +100,12 @@ configure_file(
input: 'libgobject-gdb.py.in',
output: 'libgobject-2.0.so.@0@-gdb.py'.format(library_version),
configuration: gdb_conf,
- # FIXME: Figure out how to install this on Windows
- install: host_system != 'windows',
+ # XXX: We add a leading './' because glib_libdir is an absolute path and we
+ # need it to be a relative path so that join_paths appends it to the end.
install_dir: join_paths(glib_datadir, 'gdb', 'auto-load', './' + glib_libdir)
+ # FIXME: Cannot install on Windows because the path will contain a drive
+ # letter and colons are not allowed in paths.
+ install: host_system != 'windows',
)
if enable_systemtap