summaryrefslogtreecommitdiff
path: root/gobject/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2018-05-01 09:44:19 -0400
committerPhilip Withnall <withnall@endlessm.com>2018-05-09 12:52:59 +0100
commitb6cb22f32bf3df3c21310bd10b9c122ca4b8e3f6 (patch)
treeedeac27df5feec0395236b48befd1f15eb743775 /gobject/meson.build
parente924f777369710221c3e0a9d7bf40392a27d1fa4 (diff)
downloadglib-b6cb22f32bf3df3c21310bd10b9c122ca4b8e3f6.tar.gz
Meson: Do not build tests with nodelete/Bsymbolic-functions
-z nodelete breaks the libresourceplugin module usage in the resources.c test, which expects to be able to unload it. Make the Meson build match what the autotools build does: only pass glib_link_flags to the headline libraries (glib-2.0, gio-2.0, gobject-2.0, gthread-2.0, gmodule-2.0) and omit it from all other build targets. https://bugzilla.gnome.org/show_bug.cgi?id=788771
Diffstat (limited to 'gobject/meson.build')
-rw-r--r--gobject/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/gobject/meson.build b/gobject/meson.build
index 98e306d7f..aa8f5398e 100644
--- a/gobject/meson.build
+++ b/gobject/meson.build
@@ -69,7 +69,9 @@ libgobject = library('gobject-2.0',
install : true,
include_directories : [configinc],
dependencies : [libintl, libffi_dep, libglib_dep],
- c_args : ['-DG_LOG_DOMAIN="GLib-GObject"', '-DGOBJECT_COMPILATION'] + glib_hidden_visibility_args)
+ c_args : ['-DG_LOG_DOMAIN="GLib-GObject"', '-DGOBJECT_COMPILATION'] + glib_hidden_visibility_args,
+ link_args : glib_link_flags,
+)
pkg.generate(libraries : libgobject,
requires : ['glib-2.0'],