summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <withnall@endlessm.com>2018-05-30 10:12:01 +0100
committerPhilip Withnall <withnall@endlessm.com>2018-05-30 10:12:01 +0100
commit61b2f5c8e11aa5ae38138f352334f389f2b1d058 (patch)
tree2596b5a554e1b704a38061c10bb0985d02787095 /meson.build
parent51d566ba6e657ece9769e03dbdaa7bd64c3f45f5 (diff)
downloadglib-61b2f5c8e11aa5ae38138f352334f389f2b1d058.tar.gz
build: Always enable -Wmisleading-indentation
Try and ensure that people don’t push code with misleading indentation in future. This should give fairly few false positives. Signed-off-by: Philip Withnall <withnall@endlessm.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 49cc9c3bd..6eb67cff2 100644
--- a/meson.build
+++ b/meson.build
@@ -331,6 +331,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
test_c_args = [
'-Wall',
'-Wduplicated-branches',
+ '-Wmisleading-indentation',
'-Wstrict-prototypes',
'-Wunused',
'-Werror=declaration-after-statement',