summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2019-03-27 16:25:48 +0000
committerPhilip Withnall <philip@tecnocode.co.uk>2019-03-27 16:25:48 +0000
commitad614fc0705086a59a3091c897b13a8f73763e33 (patch)
treed2f56b8ad442f43a7cf8090fe4391a03eb3a81fa /meson.build
parentd264001d79d0b0f2b963973e4833cbb96941e930 (diff)
parenta53ff7460ef6f03d8e602186b721baea16bfef9f (diff)
downloadglib-ad614fc0705086a59a3091c897b13a8f73763e33.tar.gz
Merge branch 'cygwin-rtld_next' into 'master'
Check for RTLD_NEXT See merge request GNOME/glib!750
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9622ced5c..09472deee 100644
--- a/meson.build
+++ b/meson.build
@@ -592,6 +592,12 @@ if cc.has_header_symbol('dlfcn.h', 'RTLD_GLOBAL')
glib_conf.set('HAVE_RTLD_GLOBAL', 1)
endif
+have_rtld_next = false
+if cc.has_header_symbol('dlfcn.h', 'RTLD_NEXT')
+ have_rtld_next = true
+ glib_conf.set('HAVE_RTLD_NEXT', 1)
+endif
+
# Check whether to use statfs or statvfs
# Some systems have both statfs and statvfs, pick the most "native" for these
if have_func_statfs and have_func_statvfs