summaryrefslogtreecommitdiff
path: root/gio/gdbus-2.0/codegen/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gio/gdbus-2.0/codegen/meson.build')
-rw-r--r--gio/gdbus-2.0/codegen/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/gio/gdbus-2.0/codegen/meson.build b/gio/gdbus-2.0/codegen/meson.build
index bf25cdaeb..65faae9b2 100644
--- a/gio/gdbus-2.0/codegen/meson.build
+++ b/gio/gdbus-2.0/codegen/meson.build
@@ -3,6 +3,7 @@ gdbus_codegen_files = [
'codegen.py',
'codegen_main.py',
'codegen_docbook.py',
+ 'codegen_md.py',
'codegen_rst.py',
'dbustypes.py',
'parser.py',
@@ -20,6 +21,7 @@ gdbus_codegen_conf.set('DATADIR', glib_datadir)
gdbus_codegen = configure_file(input : 'gdbus-codegen.in',
output : 'gdbus-codegen',
install_dir : get_option('bindir'),
+ install_tag : 'bin-devel',
configuration : gdbus_codegen_conf
)
# Provide tools for others when we're a subproject and they use the Meson GNOME module
@@ -31,6 +33,7 @@ gdbus_codegen_built_files = []
gdbus_codegen_built_files += configure_file(input : 'config.py.in',
output : 'config.py',
install_dir : codegen_dir,
+ install_tag : 'bin-devel',
configuration : gdbus_codegen_conf)
foreach f : gdbus_codegen_files
@@ -38,5 +41,6 @@ foreach f : gdbus_codegen_files
# and then install it too so that it can be used after installation
gdbus_codegen_built_files += configure_file(input : f, output : f,
install_dir : codegen_dir,
+ install_tag : 'bin-devel',
copy : true)
endforeach