summaryrefslogtreecommitdiff
path: root/gobject/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gobject/tests/meson.build')
-rw-r--r--gobject/tests/meson.build123
1 files changed, 107 insertions, 16 deletions
diff --git a/gobject/tests/meson.build b/gobject/tests/meson.build
index 8d568f00e..9e807463b 100644
--- a/gobject/tests/meson.build
+++ b/gobject/tests/meson.build
@@ -1,3 +1,5 @@
+subdir('performance')
+
marshalers_h = custom_target('marshalers_h',
output : 'marshalers.h',
input : 'marshalers.list',
@@ -27,13 +29,30 @@ marshalers_c = custom_target('marshalers_c',
)
gobject_tests = {
+ 'notify-init' : {},
+ 'notify-init2' : {},
+ 'custom-dispatch' : {},
'qdata' : {},
+ 'accumulator' : {
+ 'source' : ['accumulator.c', marshalers_h, marshalers_c],
+ },
+ 'basics-gobject' : {},
'boxed' : {},
- 'cxx' : {
- 'source' : ['cxx.cpp'],
+ 'defaultiface' : {
+ 'source' : ['defaultiface.c', 'testmodule.c'],
+ },
+ 'deftype' : { 'protocol': 'exitcode' },
+ 'deprecated-properties' : {},
+ 'dynamictype' : {
+ 'source' : ['dynamictype.c', 'testmodule.c'],
},
'enums' : {},
+ 'max-version' : {'install': false},
+ 'override' : {},
'param' : {},
+ 'references' : {},
+ 'basic-signals' : {},
+ 'singleton' : {},
'threadtests' : {},
'dynamictests' : {},
'binding' : {},
@@ -57,30 +76,77 @@ gobject_tests = {
'signalgroup' : {},
'testing' : {},
'type-flags' : {},
+ 'objects-refcount1' : {
+ 'c_args': cc.get_supported_arguments([
+ '-DG_DISABLE_CAST_CHECKS',
+ '-Werror',
+ '-Wcast-align=strict',
+ ]),
+ },
+ 'objects-refcount2' : {'suite' : ['slow']},
+ 'properties-refcount1' : {},
+ 'properties-refcount2' : {'suite' : ['slow']},
+ 'properties-refcount3' : {'suite' : ['slow']},
+ 'properties-refcount4' : {},
+ 'signals-refcount1' : {
+ 'source' : 'signals-refcount.c',
+ 'c_args' : ['-DTESTNUM=1'],
+ },
+ 'signals-refcount2' : {
+ 'source' : 'signals-refcount.c',
+ 'c_args' : ['-DTESTNUM=2'],
+ },
+ 'signals-refcount3' : {
+ 'source' : 'signals-refcount.c',
+ 'c_args' : ['-DTESTNUM=3'],
+ },
+ 'signals-refcount4' : {
+ 'source' : 'signals-refcount.c',
+ 'c_args' : ['-DTESTNUM=4'],
+ },
}
+if have_cxx
+ gobject_tests += {
+ 'cxx' : {
+ 'protocol': 'exitcode',
+ 'source' : ['cxx.cpp'],
+ 'suite' : ['cpp'],
+ },
+ }
+
+ foreach std, arg: cxx_standards
+ gobject_tests += {
+ 'cxx-@0@'.format(std) : {
+ 'protocol': 'exitcode',
+ 'source' : ['cxx.cpp'],
+ 'suite' : ['cpp'],
+ 'cpp_args' : [arg],
+ },
+ }
+ endforeach
+endif
+
if cc.get_id() != 'msvc'
gobject_tests += {'autoptr' : {}}
endif
-python_tests = [
- 'genmarshal.py',
- 'mkenums.py',
-]
-
-# FIXME: put common bits of test environment() in one location
-# Not entirely random of course, but at least it changes over time
-random_number = minor_version + meson.version().split('.').get(1).to_int()
+python_tests = {
+ 'genmarshal.py' : {},
+ 'gobject-query.py' : {
+ 'depends' : gobject_query,
+ 'can_fail' : host_system == 'windows',
+ },
+ 'mkenums.py' : {},
+}
test_env = environment()
test_env.set('G_TEST_SRCDIR', meson.current_source_dir())
test_env.set('G_TEST_BUILDDIR', meson.current_build_dir())
-test_env.set('G_DEBUG', 'gc-friendly')
-test_env.set('MALLOC_CHECK_', '2')
-test_env.set('MALLOC_PERTURB_', '@0@'.format(random_number % 256))
test_deps = [libm, thread_dep, libglib_dep, libgobject_dep]
test_cargs = ['-DG_LOG_DOMAIN="GLib-GObject"', '-UG_DISABLE_ASSERT']
+test_cpp_args = test_cargs
foreach test_name, extra_args : gobject_tests
source = extra_args.get('source', test_name + '.c')
@@ -95,42 +161,65 @@ foreach test_name, extra_args : gobject_tests
input: installed_tests_template_tap,
output: test_name + '.test',
install_dir: installed_tests_metadir,
+ install_tag: 'tests',
configuration: test_conf
)
endif
exe = executable(test_name, source,
c_args : test_cargs + extra_args.get('c_args', []),
+ cpp_args : test_cpp_args + extra_args.get('cpp_args', []),
dependencies : test_deps + extra_args.get('dependencies', []),
install_dir: installed_tests_execdir,
+ install_tag: 'tests',
install: install,
)
suite = ['gobject'] + extra_args.get('suite', [])
timeout = suite.contains('slow') ? test_timeout_slow : test_timeout
+ if extra_args.get('can_fail', false)
+ suite += 'failing'
+ endif
+
# FIXME: https://gitlab.gnome.org/GNOME/glib/issues/1316
# aka https://bugs.debian.org/880883
if test_name == 'closure-refcount' and ['arm', 'aarch64'].contains(host_machine.cpu_family())
timeout = timeout * 10
endif
- test(test_name, exe, env : test_env, timeout : timeout, suite : suite)
+ test(test_name,
+ exe,
+ protocol : extra_args.get('protocol', test_protocol),
+ env : test_env,
+ timeout : timeout,
+ suite : suite,
+ )
endforeach
-foreach test_name : python_tests
+foreach test_name, extra_args : python_tests
+ depends = [extra_args.get('depends', [])]
+ suite = ['gobject', 'no-valgrind']
+
+ if extra_args.get('can_fail', false)
+ suite += 'failing'
+ endif
+
test(
test_name,
python,
+ protocol : extra_args.get('protocol', test_protocol),
+ depends: depends,
args: ['-B', files(test_name)],
env: test_env,
- suite: ['gobject', 'no-valgrind'],
+ suite: suite,
)
if installed_tests_enabled
install_data(
files(test_name),
install_dir: installed_tests_execdir,
+ install_tag: 'tests',
install_mode: 'rwxr-xr-x',
)
@@ -142,6 +231,7 @@ foreach test_name : python_tests
input: installed_tests_template_tap,
output: test_name + '.test',
install_dir: installed_tests_metadir,
+ install_tag: 'tests',
configuration: test_conf,
)
endif
@@ -152,5 +242,6 @@ if installed_tests_enabled
install_data(
files('taptestrunner.py'),
install_dir: installed_tests_execdir,
+ install_tag: 'tests',
)
endif