summaryrefslogtreecommitdiff
path: root/sysdeps/sparc/elf/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/sparc/elf/configure.in')
-rw-r--r--sysdeps/sparc/elf/configure.in32
1 files changed, 1 insertions, 31 deletions
diff --git a/sysdeps/sparc/elf/configure.in b/sysdeps/sparc/elf/configure.in
index 1a2f61a90c..ec683455c7 100644
--- a/sysdeps/sparc/elf/configure.in
+++ b/sysdeps/sparc/elf/configure.in
@@ -46,35 +46,6 @@ if test $libc_cv_sparc_tls = no; then
AC_MSG_ERROR([the assembler must support TLS])
fi
-# Check for GOTDATA relocation support in assembler and linker.
-AC_CACHE_CHECK(for sparc binutils GOTDATA reloc support, libc_cv_sparc_gotdata, [dnl
-changequote(,)dnl
-cat > conftest.S <<\EOF
- .data
- .globl data
-data: .word 0
- .text
- .globl foo
-foo: sethi %gdop_hix22(data), %g1
- xor %g1, %gdop_lox10(data), %g1
-#ifdef __arch64__
- ldx [%l7 + %g1], %g1, %gdop(data)
-#else
- ld [%l7 + %g1], %g1, %gdop(data)
-#endif
-EOF
-changequote([,])dnl
-dnl
-if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.S 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_sparc_gotdata=yes
-else
- libc_cv_sparc_gotdata=no
-fi
-rm -f conftest*])
-if test $libc_cv_sparc_gotdata = yes; then
- AC_DEFINE(HAVE_BINUTILS_GOTDATA)
-fi
-
# Check for a GCC emitting GOTDATA relocations.
AC_CACHE_CHECK(for sparc gcc GOTDATA reloc support, libc_cv_sparc_gcc_gotdata, [dnl
changequote(,)dnl
@@ -99,7 +70,6 @@ if test $libc_cv_sparc_gcc_gotdata = yes; then
AC_DEFINE(HAVE_GCC_GOTDATA)
fi
-if test $libc_cv_sparc_gcc_gotdata = yes \
- && test $libc_cv_sparc_gotdata = yes; then
+if test $libc_cv_sparc_gcc_gotdata = yes; then
AC_DEFINE(PI_STATIC_AND_HIDDEN)
fi