summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@src.gnome.org>2008-03-30 02:08:36 +0000
committerJonathon Jongsma <jjongsma@src.gnome.org>2008-03-30 02:08:36 +0000
commit6231a499e7ffc05fdaed5d653da21fe456638686 (patch)
tree6af7e82a68211d33b02467522f6a86f7afaaf710 /Makefile.am
parentb7090edf6654f89a88114ac38f8d0c5d0ab93052 (diff)
downloadglibmm-6231a499e7ffc05fdaed5d653da21fe456638686.tar.gz
add some more convenience targets for making releases 2.16.1:
* Makefile.am: add some more convenience targets for making releases 2.16.1: svn path=/trunk/; revision=650
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 44 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index cc5fbee8..09baeb44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,9 +71,50 @@ tag-release: distcheck
&& echo "Try running `svn update`." && false)
@echo "Release Tagged."
-release: tag-release
+upload-release: tag-release
scp $(DIST_ARCHIVES) master.gnome.org:
@echo "Tarball uploaded. Now run install-module on master.gnome.org"
-
-.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild release tag-release
+ @echo "[hint: make install-module]"
+
+RELEASE_ANNOUNCE_LIST = gnome-announce-list@gnome.org, gtkmm-list@gnome.org
+release-announce: upload-release
+ @echo "Please send the following announcement to:"
+ @echo "$(RELEASE_ANNOUNCE_LIST)"
+ @echo ""
+ @echo "Subject: ANNOUNCE: $(PACKAGE) $(VERSION) released"
+ @echo ""
+ @echo "============================== CUT HERE =============================="
+ @echo "*** About $(PACKAGE)"
+ @echo ""
+ @echo " $(PACKAGE) is a C++ API for glib, used by gtkmm."
+ @echo ""
+ @echo " $(PACKAGE) 2.16 wraps new API in glib 2.16, including the new gio library, "
+ @echo " and is API/ABI-compatibile with glibmm 2.14, 2.12, 2.10, 2.8, 2.6 and "
+ @echo " 2.4. It is a version of the glibmm-2.4 API."
+ @echo ""
+ @echo " gtkmm and $(PACKAGE) stay in-sync with GTK+ by following the official GNOME release schedule:"
+ @echo " http://www.gnome.org/start/unstable/"
+ @echo ""
+ @echo " Bindings for the rest of the GNOME Platform are also available, and are also "
+ @echo " API-stable."
+ @echo ""
+ @echo " http://www.gtkmm.org"
+ @echo ""
+ @echo "*** Development "
+ @echo ""
+ @echo " There is active discussion on the mailing list: "
+ @echo " http://www.gtkmm.org/mailinglist.shtml"
+ @echo " and in the #c++ channel on irc.gnome.org"
+ @echo ""
+ @echo "*** Changes:"
+ @echo ""
+ @echo " --- INSERT NEWS HERE ---"
+ @echo "============================== CUT HERE =============================="
+
+install-module:
+ ssh master.gnome.org install-module $(DIST_ARCHIVES)
+
+release: release-announce
+
+.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild release tag-release upload-release release-announce install-module