summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@src.gnome.org>2008-02-29 18:04:05 +0000
committerJonathon Jongsma <jjongsma@src.gnome.org>2008-02-29 18:04:05 +0000
commit88664ef0bc2afe530e937eadf822ae55c13e6fac (patch)
tree1f76820380d23ac4a2bc5b8d463d0317bf5bf79e /Makefile.am
parent2b55481255f99f09cfb3052cb94e97f2354d9709 (diff)
downloadglibmm-88664ef0bc2afe530e937eadf822ae55c13e6fac.tar.gz
added 'release' target which will run distcheck, tag the repository with
* Makefile.am: added 'release' target which will run distcheck, tag the repository with the current version and upload the tarball to master.gnome.org svn path=/trunk/; revision=628
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 90ee5f99..a6fbe114 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,5 +59,18 @@ doc-clean: doc-clean-recursive
doc-rebuild:
(cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-rebuild)
-.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild
+SVN_REV=`svnversion -n`
+URL_KEY=URL:
+SVN_PATH=`svn info |grep "$(URL_KEY)" |sed -e "s/$(URL_KEY)\s*//"`
+ROOT_KEY=Repository Root:
+SVN_ROOT=`svn info |grep "$(ROOT_KEY)" |sed -e "s/$(ROOT_KEY)\s*//"`
+
+tag-release: distcheck
+ svn cp -m "tag $(PACKAGE) $(VERSION)" $(SVN_PATH)@$(SVN_REV) $(SVN_ROOT)/tags/$(PACKAGE)-$(VERSION)
+
+release: tag-release
+ scp $(DIST_ARCHIVES) master.gnome.org:
+ @echo "Tarball uploaded. Now run install-module on master.gnome.org"
+
+.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild release tag-release