summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jonathon@quotidian.org>2009-07-13 10:18:32 -0500
committerJonathon Jongsma <jonathon@quotidian.org>2009-07-13 11:07:28 -0500
commit0222c48af78c02ba3a55006bafd3a9f5a2e6db60 (patch)
tree9a5d30c46c6982994481c280685d303feab7e4c0 /Makefile.am
parentf7b207c790cbfca4a34b8353313ea0a1e9d862e3 (diff)
downloadglibmm-0222c48af78c02ba3a55006bafd3a9f5a2e6db60.tar.gz
fix release targets in makefile for git transitionglibmm-2.21.2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 249db987..d1801f02 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,16 +60,10 @@ doc-clean: doc-clean-recursive
doc-rebuild:
(cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-rebuild)
-SVN_REV=`svnversion -n`
-URL_KEY=URL:
-SVN_PATH=`svn info |grep "$(URL_KEY)" |sed -e "s/$(URL_KEY)\s*//"`
-ROOT_KEY=Repository Root:
-SVN_ROOT=`svn info |grep "$(ROOT_KEY)" |sed -e "s/$(ROOT_KEY)\s*//"`
+GIT = $(top_srcdir)/scripts/missing --run git
tag-release: distcheck
- @svn cp -r$(SVN_REV) -m "tag $(PACKAGE) $(VERSION)" $(SVN_PATH) $(SVN_ROOT)/tags/$(PACKAGE)-$(VERSION) \
- || (echo "Tagging failed. Do you have local changes that are not committed?" \
- && echo "Try running 'svn update'." && false)
+ $(GIT) tag -s -m "$(PACKAGE) release $(VERSION)" v$(VERSION)
@echo "Release Tagged."
upload-release: tag-release