summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@src.gnome.org>2008-12-12 02:42:07 +0000
committerJonathon Jongsma <jjongsma@src.gnome.org>2008-12-12 02:42:07 +0000
commit31b6119baf4a20ea06c1ab64ecf5db249c278cf5 (patch)
tree319865605a2daa500131813fae5ce9035602736e /Makefile.am
parent22e829e5ffbf8e39d2573772bafe90ed344066d9 (diff)
downloadglibmm-31b6119baf4a20ea06c1ab64ecf5db249c278cf5.tar.gz
Add some convenience rules for generating .defs files
At the moment the paths are tailored for my devel machine, hopefully we can generalize that in the future svn path=/trunk/; revision=752
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 38 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a8e5e233..249db987 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,5 +124,42 @@ install-module:
release: upload-release release-announce
-.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild release tag-release upload-release release-announce install-module
+#FIXME: use generic paths, rather than my particular paths
+H2DEF = env python /opt/gnome2/share/pygobject/2.0/codegen/h2def.py
+DEFS_INC_DIR = /opt/gnome2/include
+GEN_ENUM = env perl ./tools/enum.pl
+GEN_EXTRA_DEFS_GLIB = ./tools/extra_defs_gen/generate_extra_defs
+GEN_EXTRA_DEFS_GIO = ./tools/extra_defs_gen/generate_defs_gio
+DOCEXTRACT = /home/jonathon/gnome-build/pygobject/codegen/docextract_to_xml.py
+
+defs: glib-defs gio-defs docextract
+ @echo
+ @echo "*** Make sure to examine the .defs files to make sure they look reasonable"
+ @echo
+
+glib-defs:
+ $(H2DEF) $(DEFS_INC_DIR)/glib-2.0/glib/*.h > glib/src/glib_functions.defs
+ $(H2DEF) $(DEFS_INC_DIR)/glib-2.0/gobject/*.h > glib/src/gobject_functions.defs
+ $(H2DEF) $(DEFS_INC_DIR)/glib-2.0/gmodule.h > glib/src/gmodule_functions.defs
+ $(GEN_ENUM) $(DEFS_INC_DIR)/glib-2.0/glib/*.h > glib/src/glib_enums.defs
+ $(GEN_ENUM) $(DEFS_INC_DIR)/glib-2.0/gobject/*.h > glib/src/gobject_enums.defs
+ $(GEN_ENUM) $(DEFS_INC_DIR)/glib-2.0/gmodule.h > glib/src/gmodule_enums.defs
+
+gio-defs:
+ $(H2DEF) $(DEFS_INC_DIR)/glib-2.0/gio/*.h \
+ $(DEFS_INC_DIR)/gio-unix-2.0/gio/*.h > gio/src/gio_methods.defs
+ $(GEN_ENUM) $(DEFS_INC_DIR)/glib-2.0/gio/*.h \
+ $(DEFS_INC_DIR)/gio-unix-2.0/gio/*.h > gio/src/gio_enums.defs
+ $(GEN_EXTRA_DEFS_GIO) > gio/src/gio_signals.defs
+
+docextract:
+ $(DOCEXTRACT) -s ../glib/glib \
+ -s ../glib/docs/reference/glib \
+ -s ../glib/gobject \
+ -s ../glib/docs/reference/gobject > glib/src/glib_docs.xml
+ $(DOCEXTRACT) -s ../glib/gio \
+ -s ../glib/docs/reference/gio > gio/src/gio_docs.xml
+
+
+.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild release tag-release upload-release release-announce install-module defs glib-defs gio-defs docextract