summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2016-02-27 15:28:06 +0100
committerMurray Cumming <murrayc@murrayc.com>2016-02-27 15:28:06 +0100
commitda03715eb0bba919e82e01e041d2afc842807e99 (patch)
tree398ee463f964ecd77ee0cb20ae6ad3d97cbece9d /Makefile.am
parent25b4a8d167555bd080160f0b1169cd54e5aaef37 (diff)
downloadglibmm-da03715eb0bba919e82e01e041d2afc842807e99.tar.gz
manual refactor target: Error if clang-format is not available.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7473185c..a0df8afe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,5 +57,9 @@ DISTCLEANFILES = $(filter %mmconfig.h,$(msvc_files))
include $(top_srcdir)/build/dist-changelog.am
reformat:
+if HAVE_CLANG_FORMAT
$(CLANG_FORMAT) -i `find . -name "*.h"`
$(CLANG_FORMAT) -i `find . -name "*.cc"`
+else
+ $(error clang-format was not not found during configure.)
+endif