summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2016-02-26 09:25:37 +0100
committerMurray Cumming <murrayc@murrayc.com>2016-02-26 09:25:37 +0100
commit6d114bc86dedebb6c5007e7ba1abf8888879939c (patch)
treeecdc33bda3979789a3506736dd598d89b598a715 /Makefile.am
parente3e3a5da0a3bc670499bc6c60c558a2c659d21af (diff)
downloadglibmm-6d114bc86dedebb6c5007e7ba1abf8888879939c.tar.gz
Makefile.am: Added a manual reformat target, to use clang-format.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bd39e4f2..7473185c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,3 +55,7 @@ DISTCLEANFILES = $(filter %mmconfig.h,$(msvc_files))
# Auto-generate the ChangeLog file from the git log on make dist
include $(top_srcdir)/build/dist-changelog.am
+
+reformat:
+ $(CLANG_FORMAT) -i `find . -name "*.h"`
+ $(CLANG_FORMAT) -i `find . -name "*.cc"`