summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <danielk@openismus.com>2009-08-09 23:19:02 +0200
committerDaniel Elstner <danielk@openismus.com>2009-08-09 23:19:02 +0200
commitba84a26bac2353d622036fac3dc03979ec3d83fc (patch)
tree206bd2bb30948c5924012d6bf7c3bc7b28725c45 /Makefile.am
parent464e1e45a2f6ef0fefa4dadd6eaa12689770c2b1 (diff)
downloadglibmm-ba84a26bac2353d622036fac3dc03979ec3d83fc.tar.gz
Get make distcheck to pass cleanly
* Makefile.am (DISTCLEANFILES): List the configuration header copies made by the AC_CONFIG_COMMANDS() as files to delete. * configure.ac (AM_INIT_AUTOMAKE): Switch to POSIX archive format (pax) for tar, because just as with libsigc++ the filenames generated by Doxygen exceed the tar-ustar limit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 55239ebd..488faa06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,6 +50,11 @@ text_files = COPYING.tools README.win32 glib/README gio/README
msvc_files = $(msvc_net2005_data:%=MSVC_Net2005/%) $(msvc_net2008_data:%=MSVC_Net2008/%)
dist_noinst_DATA = $(text_files) $(msvc_files)
+DISTCLEANFILES = MSVC_Net2005/glibmm/glibmmconfig.h \
+ MSVC_Net2005/giomm/giommconfig.h \
+ MSVC_Net2008/glibmm/glibmmconfig.h \
+ MSVC_Net2008/giomm/giommconfig.h
+
# TODO: Obsolete; remove after grace period.
aclocal_macrodir = $(datadir)/aclocal
dist_aclocal_macro_DATA = scripts/glibmm_check_perl.m4