summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@src.gnome.org>2003-01-07 16:59:16 +0000
committerMurray Cumming <murrayc@src.gnome.org>2003-01-07 16:59:16 +0000
commit78e5bf1313f67e4cbc67fe01a408d27de7383abd (patch)
treef832445dad23cd0dcc2a116fcc1469d35316d995 /Makefile.am
downloadglibmm-78e5bf1313f67e4cbc67fe01a408d27de7383abd.tar.gz
Initial revision
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..8c62ae7d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,65 @@
+
+SUBDIRS = tools glib pango atk gdk gtk docs
+DIST_SUBDIRS = $(SUBDIRS) scripts demos examples tests
+
+EXTRA_DIST = gtkmm.spec.in \
+ build_shared/Makefile_build.am_fragment \
+ build_shared/Makefile_build_gensrc.am_fragment \
+ build_shared/Makefile_gensrc.am_fragment \
+ build_shared/Makefile_gensrc_platform.am_fragment \
+ build_shared/Makefile_build_extra.am_fragment \
+ CHANGES README.win32 PORTING
+
+
+all-local:
+ @echo "*** Everything completed ***"
+
+dist-hook:
+ @echo; echo; \
+ echo "**********************************************************"; \
+ echo "* IMPORTANT NOTICE: *"; \
+ echo "* *"; \
+ echo "* Be sure you have done a complete build before running *"; \
+ echo "* 'make dist' or 'make distcheck', because otherwise *"; \
+ echo "* the tarball will _not_ contain the dependency rules *"; \
+ echo "* generated by the compiler. *"; \
+ echo "**********************************************************"; \
+ echo; echo
+
+
+include $(top_srcdir)/docs/Makefile_web.am_fragment
+
+doc_tarball_files = \
+ docs/index.html docs/FAQ/html docs/images/*.gif \
+ docs/internal/*.txt docs/internal/*.dia docs/reference/html \
+ docs/tutorial/figures/*.png docs/tutorial/html
+
+# This doesn't work very well in a $(srcdir) != $(builddir) setup,
+# but this target is for maintainer use only anyway.
+
+gtkmm-docs.tar.gz:
+ find examples -name '*.cc' -o -name '*.h' -o -name '*.xpm' -o -name '*.xml' | \
+ tar cf - --files-from - $(doc_tarball_files) | gzip -c --best >$@
+
+# Upload documentation and examples:
+
+post-html-recursive:
+ list='docs examples'; for subdir in $$list; do \
+ test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) post-html); \
+ done
+
+post-html-local: gtkmm-docs.tar.gz
+ rsync $(rsync_args) gtkmm-docs.tar.gz $$USER@shell.sourceforge.net:$(web_path_gtkmm2)
+
+post-html: post-html-recursive post-html-local
+
+doc-clean-recursive:
+ (cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-clean)
+
+doc-clean: doc-clean-recursive
+
+doc-rebuild:
+ (cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-rebuild)
+
+.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild
+