summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <danielk@openismus.com>2009-08-09 21:28:11 +0200
committerDaniel Elstner <danielk@openismus.com>2009-08-09 21:34:13 +0200
commit90feeb3e3b0f392d418a5a48c3711e5824ab086c (patch)
treeb6197a5119b505b0aad0d71194ded246f0445fdc /Makefile.am
parent975e6813cc61d5b90c5ccd00aba12ac505dfe485 (diff)
downloadglibmm-90feeb3e3b0f392d418a5a48c3711e5824ab086c.tar.gz
Get rid of all Makefile.am in the MSVC dirs
* MSVC_Net2005/**/Makefile.am: Delete recursive build files. * MSVC_Net2008/**/Makefile.am: ditto. * MSVC_Net2005/filelist.am: New file. Recursively list all files that should go into the distribution. * MSVC_Net2008/filelist.am: ditto. * configure.ac (AC_CONFIG_FILES): Remove all Makefile outputs to the MSVC subdirectories. Combine all the remaining output files into a single argument to just one AC_CONFIG_FILES call. Follow through with a number of TODO comments and remove some old cruft which is no longer used anywhere in the module. (AC_CONFIG_COMMANDS): Copy the configuration header files into the MSVC subdirectories by making config.status execute custom configuration commands. This is easier than doing it at the Makefile level, where it was previously implemented. * Makefile.am: Include the filelist.am files from the MSVC subdirectories. (SUBDIRS): Remove MSVC_Net200[58] directories from the list. (dist_noinst_DATA): Distribute the MSVC project files. * tools/gmmproc.in: Substitute @PERL@ instead of @PERL_PATH@. * tools/generate_wrap_init.pl.in: ditto.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ffbc210..55239ebd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,7 @@ doc_subdirs = docs
else
doc_subdirs =
endif
-SUBDIRS = $(src_subdirs) glib/glibmm gio/giomm tests examples $(doc_subdirs) MSVC_Net2005 MSVC_Net2008
+SUBDIRS = $(src_subdirs) glib/glibmm gio/giomm tests examples $(doc_subdirs)
glibmm_includedir = $(includedir)/$(GLIBMM_MODULE_NAME)
glibmm_include_HEADERS = glib/glibmm.h
@@ -43,7 +43,12 @@ nodist_giomm_libinclude_HEADERS = gio/giommconfig.h
pkgconfigdir = $(libdir)/pkgconfig
nodist_pkgconfig_DATA = glib/$(GLIBMM_MODULE_NAME).pc gio/$(GIOMM_MODULE_NAME).pc
-dist_noinst_DATA = README.win32 COPYING.tools glib/README gio/README
+include $(srcdir)/MSVC_Net2005/filelist.am
+include $(srcdir)/MSVC_Net2008/filelist.am
+
+text_files = COPYING.tools README.win32 glib/README gio/README
+msvc_files = $(msvc_net2005_data:%=MSVC_Net2005/%) $(msvc_net2008_data:%=MSVC_Net2008/%)
+dist_noinst_DATA = $(text_files) $(msvc_files)
# TODO: Obsolete; remove after grace period.
aclocal_macrodir = $(datadir)/aclocal