summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-03-14 15:52:05 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-03-14 15:52:05 +0800
commitc23464d60ca307a612264428ef63fa079ff461c2 (patch)
tree460f43ecfb34683eb41aa20645f5c91b1299e6a7 /Makefile.am
parent7062e6f14eb6846f610650bc3e33572508c3b2ed (diff)
downloadglibmm-c23464d60ca307a612264428ef63fa079ff461c2.tar.gz
Visual Studio builds: Require Visual Studio 2017
Visual Studio 2017 is required to support the C++-14 features that glibmm-2.52 will require, so update the projects to 2017. Make the projects look for libsigc++-3.x as well. Also make sure that the glibmm and giomm projects are up-to-date, and drop the threading examples projects as these examples have been dropped from the tree, and ensure the headers "installed" are up-to-date.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a0df8afe..7cda466d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,10 +43,10 @@ nodist_giomm_libinclude_HEADERS = gio/giommconfig.h
pkgconfigdir = $(libdir)/pkgconfig
nodist_pkgconfig_DATA = glib/$(GLIBMM_MODULE_NAME).pc gio/$(GIOMM_MODULE_NAME).pc
-include $(srcdir)/MSVC_Net2013/filelist.am
+include $(srcdir)/MSVC_Net2017/filelist.am
text_files = COPYING.tools README.SUN README.win32
-msvc_files = $(addprefix MSVC_Net2013/,$(msvc_net2013_data))
+msvc_files = $(addprefix MSVC_Net2017/,$(msvc_net2017_data))
dist_noinst_DATA = $(text_files) $(msvc_files)
dist_noinst_SCRIPTS = autogen.sh