summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2019-03-17 12:01:19 +0100
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2019-03-17 12:01:19 +0100
commit9eb59b445384c3810a13e14cc0d4cb1665dfc61b (patch)
tree7a50b33f4feeacfe6b0ad4c4c1d456f181856759 /configure.ac
parentc095eeaee5d498b26ff4fb59a97b1b4c3c7951b7 (diff)
downloadglibmm-9eb59b445384c3810a13e14cc0d4cb1665dfc61b.tar.gz
Change the ABI to glibmm-2.62
So we can use the 2.60 version numbers for stable releases in the glibmm-2.4 ABI series. We don't need to release a stable ABI-parallel glibmm until we need to release gtkmm 4.0, and that won't happen until GTK 4.0.0 happens. We've done similar ABI name changes several times before.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ed2fbc53..943039e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@
## You should have received a copy of the GNU Lesser General Public License
## along with this library. If not, see <http://www.gnu.org/licenses/>.
-AC_INIT([glibmm], [2.59.1],
+AC_INIT([glibmm], [2.61.1],
[https://gitlab.gnome.org/GNOME/glibmm/issues],
[glibmm], [http://www.gtkmm.org/])
AC_PREREQ([2.59])
@@ -31,8 +31,8 @@ AM_MAINTAINER_MODE
AC_ARG_VAR([ACLOCAL_FLAGS], [aclocal flags, e.g. -I <macro dir>])
MM_PREREQ([0.9.12])
-MM_INIT_MODULE([glibmm-2.60])
-MM_INIT_MODULE([giomm-2.60])
+MM_INIT_MODULE([glibmm-2.62])
+MM_INIT_MODULE([giomm-2.62])
# Copy the mm-common .pl scripts into docs/,
# and use them from there,
@@ -43,7 +43,7 @@ MM_CONFIG_DOCTOOL_DIR([docs])
AC_SUBST([LIBGLIBMM_SO_VERSION], [4:0:3])
AC_PROG_CXX
-MM_AX_CXX_COMPILE_STDCXX([17], [noext],[mandatory])
+MM_AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
AC_DISABLE_STATIC
LT_INIT([win32-dll])
@@ -82,7 +82,7 @@ AS_IF([test "x$enable_static" = xyes],
AC_DEFINE([GIOMM_STATIC_LIB], [1], [Define if giomm is built as a static library])
])
-glibreq='2.0 >= 2.55.1'
+glibreq='2.0 >= 2.59.2'
GLIBMM_MODULES="sigc++-3.0 >= 2.99.5 glib-$glibreq gobject-$glibreq gmodule-$glibreq"
GIOMM_MODULES="$GLIBMM_MODULES gio-$glibreq"