summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2015-07-09 22:50:41 +0200
committerMurray Cumming <murrayc@murrayc.com>2015-07-09 22:50:41 +0200
commitab7f780442703ceba9549a6525b73cad0961ecc4 (patch)
treeacf03e0fdad6487fc7b8bdd111e81123611005b5 /configure.ac
parentd6f7c5f69a8ee5935de75c87378b873967119100 (diff)
downloadglibmm-ab7f780442703ceba9549a6525b73cad0961ecc4.tar.gz
Require C++11.
configure.ac: Use AX_CXX_COMPILE_STDCXX_11 to check for compiler support for C++11 and use it (--std=c++11 for current versions of g++).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 57128644..f690a520 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,8 @@ MM_CONFIG_DOCTOOL_DIR([docs])
AC_SUBST([LIBGLIBMM_SO_VERSION], [4:0:3])
AC_PROG_CXX
+AX_CXX_COMPILE_STDCXX_11([noext],[mandatory])
+
AC_DISABLE_STATIC
LT_INIT([win32-dll])
MM_PATH_PERL