summaryrefslogtreecommitdiff
path: root/gio/meson.build
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2023-01-04 14:39:23 +0100
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2023-01-04 14:39:23 +0100
commitf740338520a691bb962a2e8d21b28a7f0a086ce1 (patch)
tree1f4d233228093855e6a8e7fc3b19d09066765bad /gio/meson.build
parentf674418a4564294b5bb77e3c9a72b31ab28122b4 (diff)
downloadglibmm-f740338520a691bb962a2e8d21b28a7f0a086ce1.tar.gz
Meson build: Don't copy files with configure_file()
It's deprecated from Meson 0.64. The replacement, fs.copyfile(), is not useful here. It only copies from the source directory to the build directory.
Diffstat (limited to 'gio/meson.build')
-rw-r--r--gio/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/gio/meson.build b/gio/meson.build
index 4213109f..096617f3 100644
--- a/gio/meson.build
+++ b/gio/meson.build
@@ -20,9 +20,10 @@ configure_file(
configuration: giomm_pkg_uninst_conf_data,
)
+giommconfig_h_meson = files('giommconfig.h.meson')
install_giommconfigdir = install_libdir / giomm_pcname / 'include'
-giommconfig_h = configure_file(
- input: 'giommconfig.h.meson',
+configure_file(
+ input: giommconfig_h_meson,
output: 'giommconfig.h',
configuration: pkg_conf_data,
install_dir: install_giommconfigdir,