summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2020-03-04 11:19:42 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2020-03-05 16:13:30 +0800
commit4c2b07e68fbacbb09dcf91b44ee8cd1312ae9f21 (patch)
treefcfe0bc02e7266ec386cc2496a8fa9cdb539d4e8 /meson.build
parentdeef6e7d4629dfaa913c2c4c44f05bf5cfc382a8 (diff)
downloadglibmm-4c2b07e68fbacbb09dcf91b44ee8cd1312ae9f21.tar.gz
meson: Use /utf-8 for Visual Studio builds
This way, we can avoid warning/error C4819 when building glibmm due to unicode handling issues in the compiler, which is likely to pop up on East Asian locales on Windows. We need to ignore warning C4828 when building gendef.exe though with this.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 945fbdaa..29a0b1b5 100644
--- a/meson.build
+++ b/meson.build
@@ -189,7 +189,7 @@ add_project_arguments(warning_flags, language: 'cpp')
# that should not be overlooked stand out.
if is_msvc
disabled_warnings = cpp_compiler.get_supported_arguments([
- '/FImsvc_recommended_pragmas.h', '/wd4267', '/wd4530', '/wd4589'
+ '/FImsvc_recommended_pragmas.h', '/wd4267', '/wd4530', '/wd4589', '/utf-8'
])
add_project_arguments(disabled_warnings, language: 'cpp')
endif