summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2020-09-30 17:19:02 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2020-09-30 17:19:02 +0200
commita7befa0b936e43b765c9d0b2716a8a27e5c87a11 (patch)
tree6312b7b8418df92531e0657945040f8ea0f8ecc8 /meson.build
parent6d07bfe291edf7dc62bbf088f6002f604353b684 (diff)
downloadglibmm-a7befa0b936e43b765c9d0b2716a8a27e5c87a11.tar.gz
Meson build: Fix versioning on macOS
See https://github.com/libsigcplusplus/libsigcplusplus/pull/65
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 20ae62eb..4d2c13a6 100644
--- a/meson.build
+++ b/meson.build
@@ -30,7 +30,12 @@ libtool_soversion = [4, 0, 3]
glibmm_libversion = '@0@.@1@.@2@'.format(
libtool_soversion[0] - libtool_soversion[2],
libtool_soversion[2],
- libtool_soversion[1])
+ libtool_soversion[1]
+)
+macos_darwin_versions = [
+ libtool_soversion[0] + 1,
+ '@0@.@1@'.format(libtool_soversion[0] + 1, libtool_soversion[1])
+]
# Use these instead of meson.source_root() and meson.build_root() in subdirectories.
# source_root() and build_root() are not useful, if this is a subproject.