summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2020-03-05 16:01:13 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2020-03-07 23:22:32 +0800
commitd84be37aaa335e57bb6fe7de6bf4be736652a60d (patch)
tree48a6efc940aa127f762f0168ba0a9234c7ae4d39 /meson.build
parentb55811ea37fc26f6815a18a4d6dc24dae78354fb (diff)
downloadglibmm-d84be37aaa335e57bb6fe7de6bf4be736652a60d.tar.gz
build: Do not use gendef.exe for glibmm
Clean up the build files a bit and update the glibmmconfig.h.[in|meson] so that we use __declspec(dllexport) when GLIBMM_BUILD is defined (i.e. during the build of glibmm) on Visual Studio. Also, for the meson builds, disable warnings 4251 and 4275 as they all relate to building DLLs regarding symbol export, which is harmless as we know clearly that we are indeed building DLLs in our case, and we have already set GLIBMM_API appropriately
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 29a0b1b5..2636e563 100644
--- a/meson.build
+++ b/meson.build
@@ -189,7 +189,7 @@ add_project_arguments(warning_flags, language: 'cpp')
# that should not be overlooked stand out.
if is_msvc
disabled_warnings = cpp_compiler.get_supported_arguments([
- '/FImsvc_recommended_pragmas.h', '/wd4267', '/wd4530', '/wd4589', '/utf-8'
+ '/FImsvc_recommended_pragmas.h', '/wd4251', '/wd4275', '/wd4267', '/wd4530', '/wd4589', '/utf-8'
])
add_project_arguments(disabled_warnings, language: 'cpp')
endif