summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2021-05-07 12:25:00 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2021-05-07 12:25:00 +0800
commiteabcc013a3d6f9863c01a51142514423b4aa8c04 (patch)
treeeefd50064613c590a9950a5c845f832f0c7dceef /meson.build
parent29b9a102832b87a607410f455290d3da377283b0 (diff)
downloadglibmm-eabcc013a3d6f9863c01a51142514423b4aa8c04.tar.gz
Clean up Visual Studio build files
Stop ignoring warnings C4251, C4273 and C4275 and add /EHsc in the compiler flags, so that we know if we are inadvertedly tying ourselves too closely to a Visual Studio compiler/STL version
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2f7144a5..df3bf517 100644
--- a/meson.build
+++ b/meson.build
@@ -209,7 +209,7 @@ msvc14x_toolset_ver = ''
# that should not be overlooked stand out.
if is_msvc
disabled_warnings = cpp_compiler.get_supported_arguments([
- '/FImsvc_recommended_pragmas.h', '/wd4251', '/wd4275', '/wd4267', '/wd4530', '/wd4589', '/utf-8'
+ '/FImsvc_recommended_pragmas.h', '/wd4267', '/EHsc', '/utf-8'
])
add_project_arguments(disabled_warnings, language: 'cpp')