summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2020-04-05 15:51:44 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2020-04-05 15:51:44 +0200
commit60b28e75eed154d265ccd480cc151cfba90bddda (patch)
tree86f86ff12a2135b7eead0fab94f2d2041d10e703 /meson_options.txt
parent065bd678c2b88613b93e6a900aab9cb8cd7a21a4 (diff)
downloadglibmm-60b28e75eed154d265ccd480cc151cfba90bddda.tar.gz
Meson build: Set default value of the 'warnings' option to 'min'
* meson.build: Use dist-warnings when a tarball is tested by 'ninja dist' or 'meson dist'. Check if generate-binding.py exists, if not maintainer-mode. Add a better error message if mm-common-get is required but not found. * meson_options.txt: Set default value of the 'warnings' to 'min'. Add 'dist-warnings' with default value 'fatal'.
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson_options.txt b/meson_options.txt
index b5a526c3..0fc1e1d7 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -1,7 +1,9 @@
option('maintainer-mode', type: 'combo', choices: ['false', 'if-git-build', 'true'],
value: 'if-git-build', description: 'Generate source code from .hg and .ccg files')
-option('warnings', type: 'combo', choices: ['no', 'min', 'max', 'fatal'], value: 'fatal',
- description: 'Compiler warning level')
+option('warnings', type: 'combo', choices: ['no', 'min', 'max', 'fatal'],
+ value: 'min', description: 'Compiler warning level')
+option('dist-warnings', type: 'combo', choices: ['no', 'min', 'max', 'fatal'],
+ value: 'fatal', description: 'Compiler warning level when a tarball is created')
option('build-deprecated-api', type: 'boolean', value: true,
description: 'Build deprecated API and include it in the library')
option('build-documentation', type: 'combo', choices: ['false', 'if-maintainer-mode', 'true'],