summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am77
1 files changed, 64 insertions, 13 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 46fcd26b..5d69948f 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,21 +1,72 @@
-example_dirs = child_watch compose iochannel_stream markup options properties regex thread keyfile network_io
+## Copyright (c) 2009 Openismus GmbH <http://www.openismus.com/>
+##
+## This file is part of glibmm.
+##
+## glibmm is free software: you can redistribute it and/or modify it
+## under the terms of the GNU Lesser General Public License as published
+## by the Free Software Foundation, either version 2.1 of the License,
+## or (at your option) any later version.
+##
+## glibmm is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+## See the GNU Lesser General Public License for more details.
+##
+## You should have received a copy of the GNU Lesser General Public License
+## along with this library. If not, see <http://www.gnu.org/licenses/>.
-# These use gtkmm stuff:
-# thread
+AUTOMAKE_OPTIONS = subdir-objects
-SUBDIRS = $(example_dirs)
-EXTRA_DIST = README Makefile.am_fragment
+check_PROGRAMS = \
+ child_watch/child_watch \
+ compose/example \
+ iochannel_stream/example \
+ keyfile/example \
+ markup/parser \
+ network_io/resolve \
+ options/example \
+ properties/example \
+ regex/example \
+ thread/dispatcher \
+ thread/dispatcher2 \
+ thread/thread \
+ thread/threadpool
-#Web upload:
-include $(top_srcdir)/docs/Makefile_web.am_fragment
+glibmm_includes = -I$(top_builddir)/glib $(if $(srcdir:.=),-I$(top_srcdir)/glib)
+giomm_includes = -I$(top_builddir)/gio $(if $(srcdir:.=),-I$(top_srcdir)/gio)
+local_cppflags = -I$(top_builddir) $(glibmm_includes) $(giomm_includes)
-web_path = $(web_path_gtkmm)examples
+AM_CPPFLAGS = $(local_cppflags) $(GTHREAD_CFLAGS) $(GIOMM_CFLAGS)
+AM_CXXFLAGS = $(GLIBMM_WXXFLAGS)
-#rsync --cvs-exclude ignores *.o and anything in .cvsignore and some more:
-rsync_options = -vzr --rsh ssh --cvs-exclude --delete-excluded --exclude=.libs --exclude=.deps --exclude=core --exclude=.cvsignore --exclude=a.out --exclude=Makefile --exclude=Makefile.in
+local_libglibmm = $(top_builddir)/glib/glibmm/libglibmm-$(GLIBMM_API_VERSION).la
+local_libgiomm = $(top_builddir)/gio/giomm/libgiomm-$(GIOMM_API_VERSION).la
-post-html:
- rsync $(rsync_options) $(example_dirs) $$USER@$(web_host):$(web_path)
+LDADD = $(GLIBMM_LIBS) $(local_libglibmm)
+giomm_ldadd = $(GIOMM_LIBS) $(local_libglibmm) $(local_libgiomm)
+thread_ldadd = $(GTHREAD_LIBS) $(GLIBMM_LIBS) $(local_libglibmm)
-.PHONY: post-html
+child_watch_child_watch_SOURCES = child_watch/main.cc
+iochannel_stream_example_SOURCES = \
+ iochannel_stream/fdstream.cc \
+ iochannel_stream/fdstream.h \
+ iochannel_stream/main.cc
+compose_example_SOURCES = compose/main.cc
+keyfile_example_SOURCES = keyfile/main.cc
+markup_parser_SOURCES = markup/parser.cc
+options_example_SOURCES = options/main.cc
+properties_example_SOURCES = properties/properties_example.cc
+regex_example_SOURCES = regex/main.cc
+
+thread_dispatcher_SOURCES = thread/dispatcher.cc
+thread_dispatcher_LDADD = $(thread_ldadd)
+thread_dispatcher2_SOURCES = thread/dispatcher2.cc
+thread_dispatcher2_LDADD = $(thread_ldadd)
+thread_thread_SOURCES = thread/thread.cc
+thread_thread_LDADD = $(thread_ldadd)
+thread_threadpool_SOURCES = thread/threadpool.cc
+thread_threadpool_LDADD = $(thread_ldadd)
+
+network_io_resolve_SOURCES = network_io/resolve.cc
+network_io_resolve_LDADD = $(giomm_ldadd)