summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2001-11-15 22:27:41 +0100
committerKevin Ryde <user42@zip.com.au>2001-11-15 22:27:41 +0100
commit3db5e61327668e5b1c4e517161b660251cbee3a7 (patch)
tree3b5dd72790b9773a4c0a1e41dc93c22131f5a899 /Makefile.am
parentcc9aa932213e08202b0cc306f739a21d5d5ea613 (diff)
downloadgmp-3db5e61327668e5b1c4e517161b660251cbee3a7.tar.gz
* scanf/doscan.c, scanf/fscanf.c, scanf/fscanffuns.c, scanf/scanf.c,
scanf/sscanf.c, scanf/sscanffuns.c, scanf/vfscanf.c, scanf/vscanf.c, scanf/vsscanf.c, scanf/Makefile.am, tests/misc/t-scanf.c: New files. * gmp-h.in, gmp-impl.h, Makefile.am, configure.in: Consequent additions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e76f936b7..c10c97f4a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,7 +78,7 @@ endif
# "tests" ahead of "mpfr" ensures tests/t-constants is run before the
# mpfr/tests programs.
#
-SUBDIRS = tests mpn mpz mpq mpf printf cxx mpbsd $(MPFR_DIR) demos tune
+SUBDIRS = tests mpn mpz mpq mpf printf scanf cxx mpbsd $(MPFR_DIR) demos tune
if WANT_CXX
GMPXX_HEADERS_OPTION = gmpxx.h
@@ -194,6 +194,11 @@ PRINTF_OBJECTS = \
printf/vsnprintf$U.lo printf/vsprintf$U.lo \
@REPL_VSNPRINTF_PRINTF_OBJ@
+SCANF_OBJECTS = \
+ scanf/doscan$U.lo scanf/fscanf$U.lo scanf/fscanffuns$U.lo \
+ scanf/scanf$U.lo scanf/sscanf$U.lo scanf/sscanffuns$U.lo \
+ scanf/vfscanf$U.lo scanf/vscanf$U.lo scanf/vsscanf$U.lo
+
CXX_OBJECTS = \
cxx/isfuns$U.lo cxx/ismpf$U.lo cxx/ismpq$U.lo cxx/ismpz$U.lo \
cxx/osdoprnti$U.lo cxx/osmpf$U.lo cxx/osmpq$U.lo cxx/osmpz$U.lo
@@ -224,7 +229,8 @@ libgmp_la_SOURCES = gmp-impl.h longlong.h \
rand.c randclr.c randlc.c randlc2x.c randraw.c rands.c randsd.c randsdui.c \
version.c
libgmp_la_DEPENDENCIES = @TAL_OBJECT@ \
- $(MPF_OBJECTS) $(MPZ_OBJECTS) $(MPN_OBJECTS) $(MPQ_OBJECTS) $(PRINTF_OBJECTS)
+ $(MPF_OBJECTS) $(MPZ_OBJECTS) $(MPN_OBJECTS) $(MPQ_OBJECTS) \
+ $(PRINTF_OBJECTS) $(SCANF_OBJECTS)
libgmp_la_LIBADD = $(libgmp_la_DEPENDENCIES)
libgmp_la_LDFLAGS = $(GMP_LDFLAGS) \
-version-info $(LIBGMP_LT_CURRENT):$(LIBGMP_LT_REVISION):$(LIBGMP_LT_AGE)