summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2003-10-24 21:27:48 +0200
committerKevin Ryde <user42@zip.com.au>2003-10-24 21:27:48 +0200
commit167169f45de4946ebf42e9a8766b05c0a666255c (patch)
tree0361c2167ebdc80c6a95aef78d3f1fdcccce9131 /Makefile.am
parent5b129f18b1ed17138266b1b6df09b92e650ee913 (diff)
downloadgmp-167169f45de4946ebf42e9a8766b05c0a666255c.tar.gz
* Makefile.am: Amend comments about not building from libtool
convenience libraries.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d185a53b..7223a14d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -227,18 +227,19 @@ MPBSD_OBJECTS = mpbsd/add$U.lo mpbsd/tdiv_qr$U.lo mpbsd/set$U.lo \
mpbsd/sdiv$U.lo mpbsd/sqrtrem$U.lo mpbsd/xtom$U.lo
-# In the current libtool it doesn't work to build libgmp.la from convenience
+# In libtool 1.5 it doesn't work to build libgmp.la from the convenience
# libraries like mpz/libmpz.la. Or rather it works, but it ends up putting
-# PIC objects into libgmp.a when shared and static are both built.
+# PIC objects into libgmp.a if shared and static are both built. (The PIC
+# objects go into mpz/.libs/libmpz.a, and thence into .libs/libgmp.a.)
#
# For now the big lists of objects above are used. Something like mpz/*.lo
# would probably work, but might risk missing something out or getting
# something extra. The source files for each .lo are listed in the
# Makefile.am's in the subdirectories.
#
-# Currently, unlike libmp below, we're not using -export-symbols, since the
-# tune and speed programs, and perhaps some of the test programs, want to
-# access undocumented symbols.
+# Currently, for libgmp, unlike libmp below, we're not using
+# -export-symbols, since the tune and speed programs, and perhaps some of
+# the test programs, want to access undocumented symbols.
libgmp_la_SOURCES = gmp-impl.h longlong.h \
assert.c compat.c errno.c extract-dbl.c insert-dbl.c invalid.c memory.c \