summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2002-06-22 00:33:55 +0200
committerKevin Ryde <user42@zip.com.au>2002-06-22 00:33:55 +0200
commit1b3cc74fde2ad822352e53544b438de20488fc0d (patch)
tree44acc66b4c08213572d4114024b6af91bdb0f3b8 /Makefile.am
parentf5fe185355df63b444358021fc0400c85702543e (diff)
downloadgmp-1b3cc74fde2ad822352e53544b438de20488fc0d.tar.gz
* Makefile.am: Add mp.h to BUILT_SOURCES, distclean all BUILT_SOURCES,
use += more. And fix a typo in the mp_bases.h rule (should rm mp_bases.h not mpn/mp_bases.c).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 26 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 32e43817a..37e74ce44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,23 +85,23 @@ endif
#
SUBDIRS = tests mpn mpz mpq mpf printf scanf cxx mpbsd $(MPFR_DIR) demos tune
+EXTRA_DIST = doc macos configfsf.guess configfsf.sub .gdbinit INSTALL.autoconf
+
if WANT_CXX
GMPXX_HEADERS_OPTION = gmpxx.h
if WANT_MPFR
MPFRXX_HEADERS_OPTION = mpfrxx.h
endif
endif
+EXTRA_DIST += gmpxx.h mpfrxx.h
+
include_HEADERS = $(GMPXX_HEADERS_OPTION) $(MPFRXX_HEADERS_OPTION)
nodist_include_HEADERS = gmp.h $(MPBSD_HEADERS_OPTION)
lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION) $(MPBSD_LTLIBRARIES_OPTION)
-BUILT_SOURCES = gmp.h mp_bases.h mpn/mp_bases.c
+BUILT_SOURCES = gmp.h
-EXTRA_DIST = doc macos \
- configfsf.guess configfsf.sub .gdbinit INSTALL.autoconf libmp.sym \
- gmpxx.h mpfrxx.h dumbmp.c gen-bases.c
-
-DISTCLEANFILES = $(nodist_include_HEADERS) config.m4 @gmp_srclinks@
+DISTCLEANFILES = $(BUILT_SOURCES) config.m4 @gmp_srclinks@
# Tell gmp.h it's building gmp, not an application, used by windows DLL stuff.
INCLUDES=-D__GMP_WITHIN_GMP
@@ -266,6 +266,7 @@ if WANT_MPBSD
MPBSD_HEADERS_OPTION = mp.h
MPBSD_LTLIBRARIES_OPTION = libmp.la
endif
+BUILT_SOURCES += mp.h
libmp_la_SOURCES = assert.c errno.c memory.c mp_bpl.c mp_clz_tab.c \
mp_minv_tab.c mp_set_fns.c
libmp_la_DEPENDENCIES = $(srcdir)/libmp.sym \
@@ -277,6 +278,7 @@ libmp_la_LIBADD = $(libmp_la_DEPENDENCIES)
libmp_la_LDFLAGS = $(GMP_LDFLAGS) \
-version-info $(LIBMP_LT_CURRENT):$(LIBMP_LT_REVISION):$(LIBMP_LT_AGE) \
-export-symbols $(srcdir)/libmp.sym
+EXTRA_DIST += libmp.sym
# Optional objects, listed in a dummy library to generate ansi2knr rules and
@@ -288,26 +290,37 @@ libdummy_la_SOURCES = tal-debug.c tal-notreent.c tal-reent.c
info_TEXINFOS = gmp.texi
gmp_TEXINFOS = fdl.texi
-
+#
# Generated by current texinfo.tex when processing gmp.texi.
-# FIXME: Automake ought to do this.
+# FIXME: Automake 1.6.3 will clean this itself.
MOSTLYCLEANFILES = gmp.tmp
+# The ansi2knr setups for the build programs are the same as the normal
+# automake ansi2knr rules, but using $(CC_FOR_BUILD) instead of $(CC). The
+# "test -f" support for srcdir!=builddir is likewise the same as automake
+# generates.
+#
+# The generated .h files are BUILT_SOURCES since they're used by gmp-impl.h
+# and hence must exist before compiling anything. The .c files don't have
+# to be BUILT_SOURCES, but are done that way to get all the built-time stuff
+# over with at the start.
+#
+EXTRA_DIST += dumbmp.c
+
mp_bases.h: gen-bases$(EXEEXT_FOR_BUILD)
- ./gen-bases header $(BITS_PER_MP_LIMB) $(GMP_NAIL_BITS) >mp_bases.h || (rm -f mpn/mp_bases.c; exit 1)
-DISTCLEANFILES += mp_bases.h
+ ./gen-bases header $(BITS_PER_MP_LIMB) $(GMP_NAIL_BITS) >mp_bases.h || (rm -f mp_bases.h; exit 1)
+BUILT_SOURCES += mp_bases.h
mpn/mp_bases.c: gen-bases$(EXEEXT_FOR_BUILD)
./gen-bases table $(BITS_PER_MP_LIMB) $(GMP_NAIL_BITS) >mpn/mp_bases.c || (rm -f mpn/mp_bases.c; exit 1)
-DISTCLEANFILES += mpn/mp_bases.c
+BUILT_SOURCES += mpn/mp_bases.c
-# Same "test -f" stuff as in a normal compile rule.
gen-bases$(EXEEXT_FOR_BUILD): gen-bases$(U_FOR_BUILD).c dumbmp.c
$(CC_FOR_BUILD) `test -f gen-bases$(U_FOR_BUILD).c || echo '$(srcdir)/'`gen-bases$(U_FOR_BUILD).c -o gen-bases$(EXEEXT_FOR_BUILD) $(LIBM_FOR_BUILD)
DISTCLEANFILES += gen-bases$(EXEEXT_FOR_BUILD)
+EXTRA_DIST += gen-bases.c
-# Same as a normal ansi2knr rule, but using $(CC_FOR_BUILD)
gen-bases_.c: gen-bases.c $(ANSI2KNR)
$(CPP_FOR_BUILD) `if test -f $(srcdir)/gen-bases.c; then echo $(srcdir)/gen-bases.c; else echo gen-bases.c; fi` | sed 's/^# \([0-9]\)/#line \1/' | $(ANSI2KNR) > gen-bases_.c || rm -f gen-bases_.c