summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2003-03-07 01:02:50 +0100
committerKevin Ryde <user42@zip.com.au>2003-03-07 01:02:50 +0100
commit8e8a6c5e9ddca3cebfd568d4779004e04d3fd82a (patch)
tree86f1dc4dbcb729ef3e49d60ee325d2c7b2c84134 /Makefile.am
parent89d3f5fcdbc1ae7e2241a7d50af248faf9cd7339 (diff)
downloadgmp-8e8a6c5e9ddca3cebfd568d4779004e04d3fd82a.tar.gz
* Makefile.am: Put gmp.h and mp.h under $(exec_prefix)/include.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a00ce93b..64986464f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,8 +91,18 @@ GMPXX_HEADERS_OPTION = gmpxx.h
endif
EXTRA_DIST += gmpxx.h
+# gmp.h and mp.h are architecture dependent, mainly since they encode the
+# limb size used in libgmp. For that reason they belong under $exec_prefix
+# not $prefix, strictly speaking.
+#
+# $exec_prefix/include is not in the default include path for gcc built to
+# the same $prefix and $exec_prefix, which might mean gmp.h is not found,
+# but anyone knowledgable enough to be playing with exec_prefix will be able
+# to address that.
+#
+includeexecdir = $(exec_prefix)/include
include_HEADERS = $(GMPXX_HEADERS_OPTION)
-nodist_include_HEADERS = gmp.h $(MPBSD_HEADERS_OPTION)
+nodist_includeexec_HEADERS = gmp.h $(MPBSD_HEADERS_OPTION)
lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION) $(MPBSD_LTLIBRARIES_OPTION)
BUILT_SOURCES = gmp.h