summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTorbjorn Granlund <tege@gmplib.org>2013-01-15 00:53:27 +0100
committerTorbjorn Granlund <tege@gmplib.org>2013-01-15 00:53:27 +0100
commite41a818cb19ffed192fc02e3cae2721421aadf62 (patch)
tree1f5c0677582e28300f298baa6eaf4560a2193689 /configure.ac
parent3e48040ca8bf3705610e18a42d3b1e3760a8d99f (diff)
downloadgmp-e41a818cb19ffed192fc02e3cae2721421aadf62.tar.gz
Add x32 ABI for x86_64.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e09994ce5..97e3374b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1668,9 +1668,21 @@ case $host in
CALLING_CONVENTIONS_OBJS_64='amd64call.lo amd64check$U.lo'
SPEED_CYCLECOUNTER_OBJ_64=x86_64.lo
cyclecounter_size_64=2
- abilist="64 32"
+
+ cclist_x32="gcc"
+ gcc_x32_cflags="$gcc_cflags -mx32"
+ gcc_x32_cflags_optlist="$gcc_64_cflags_optlist"
+ CALLING_CONVENTIONS_OBJS_x32="$CALLING_CONVENTIONS_OBJS_64"
+ SPEED_CYCLECOUNTER_OBJ_x32="$SPEED_CYCLECOUNTER_OBJ_64"
+ cyclecounter_size_x32="$cyclecounter_size_64"
+ path_x32="$path_64"
+ limb_x32=longlong
+ any_x32_testlist="sizeof-long-4"
+
+ abilist="64 x32 32"
if test "$enable_assembly" = "yes" ; then
extra_functions_64="invert_limb_table"
+ extra_functions_x32=$extra_functions_64
fi
case $host in
@@ -3427,7 +3439,7 @@ if test "$gmp_asm_syntax_testing" != no; then
GMP_INCLUDE_MPN(x86/darwin.m4) ;;
esac
;;
- 64)
+ 64|x32)
GMP_INCLUDE_MPN(x86_64/x86_64-defs.m4)
AC_DEFINE(HAVE_HOST_CPU_FAMILY_x86_64)
case $host in