summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortege <tege@gmplib.org>2000-06-08 16:12:18 +0200
committertege <tege@gmplib.org>2000-06-08 16:12:18 +0200
commit9eff1e6563045963acdf4da67d863e54c3e5ec32 (patch)
tree6dcd6399f7bad32ec9ce602cfeabecbab3b68bcb /configure.in
parent77b0c8112adf19141c36870f2b04c9846bf5a670 (diff)
downloadgmp-9eff1e6563045963acdf4da67d863e54c3e5ec32.tar.gz
* (alpha*-*-osf*): Default `flavour' to ev6 for ev6 and higher.
* (alpha*-*-*): Likewise. * (alpha*-*-osf*: gmp_optcflags_cc): Move -arch/-tune flags from gmp_xoptcflags_gcc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3e5ab955d..ed803b618 100644
--- a/configure.in
+++ b/configure.in
@@ -103,17 +103,24 @@ case "$target" in
alpha*-*-osf*)
flavour=`echo $target_cpu | sed 's/^alpha//g'`
if test -n "$flavour"; then
+ case $flavour in # compilers don't seem to understand `ev67' and such.
+ ev6? | ev7*) flavour=ev6;;
+ esac
gmp_optcflags_gcc="-mcpu=$flavour"
# FIXME: We shouldn't fail fatally if none of these work, but that's
# how xoptcflags work and we don't have any other mechanism right now.
+ # Why do we need this here and not for alpha*-*-* below?
gmp_xoptcflags_gcc="-Wa,-arch,${flavour} -Wa,-m${flavour}"
- gmp_cflags_cc="$gmp_cflags_cc -arch $flavour -tune $flavour"
+ gmp_optcflags_cc="-arch $flavour -tune $flavour"
fi
;;
alpha*-*-*)
cclist="gcc"
flavour=`echo $target_cpu | sed 's/^alpha//g'`
if test -n "$flavour"; then
+ case $flavour in
+ ev6? | ev7*) flavour=ev6;;
+ esac
gmp_optcflags_gcc="-mcpu=$flavour"
fi
;;