summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2001-02-16 00:57:48 +0100
committerKevin Ryde <user42@zip.com.au>2001-02-16 00:57:48 +0100
commit4502543313596b75b7a2250065e0c2b46d9fe7cb (patch)
tree861a6741a4bb9a8140f709bda0387edcab9d65c4 /configure.in
parentc173dca43031c0634960b2c0f572b4e4bcdcb513 (diff)
downloadgmp-4502543313596b75b7a2250065e0c2b46d9fe7cb.tar.gz
* configure.in: Fix flags selection when $CC is a compiler known to us.
cclist_per_abi wasn't getting set, fix this and use the name cclist_abi. Also fix a typo in the ABI= config.log output.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index f425b80e1..1822bdc14 100644
--- a/configure.in
+++ b/configure.in
@@ -736,7 +736,7 @@ CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
cat >&AC_FD_CC <<EOF
configure:__line__: User:
-ABI=$CC
+ABI=$ABI
CC=$CC
CFLAGS=$CFLAGS_or_unset
CPPFLAGS=$CPPFLAGS_or_unset
@@ -781,8 +781,8 @@ for abi in $abilist; do
if test $abi = $abi_last; then abi2=; else abi2="$abi1"; fi
# Compiler choices under this ABI
- eval cclist_chosen=\"\$cclist$abi1\"
- test -n "$cclist_chosen" || eval cclist_chosen=\"\$cclist$abi2\"
+ eval cclist_abi=\"\$cclist$abi1\"
+ test -n "$cclist_abi" || eval cclist_abi=\"\$cclist$abi2\"
# If there's a user specified $CC then don't use a list for
# $cclist_chosen, just a single value for $ccbase.
@@ -795,7 +795,7 @@ for abi in $abilist; do
for ccbase in $CC; do break; done
ccbase=`echo $ccbase | sed 's:.*/::'`
- # If this $ccbase is in $cclist_chosen then it's a compiler we know and
+ # If this $ccbase is in $cclist_abi then it's a compiler we know and
# we can do flags defaulting with it. If not, then $cclist_chosen is
# set to "unrecognised" so no default flags are used.
#
@@ -806,7 +806,7 @@ for abi in $abilist; do
# unknown compiler.
#
cclist_chosen=unrecognised
- for i in $cclist_per_abi; do
+ for i in $cclist_abi; do
if test "$ccbase" = $i; then
cclist_chosen=$ccbase
break