summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortege <tege@gmplib.org>2007-09-24 17:31:56 +0200
committertege <tege@gmplib.org>2007-09-24 17:31:56 +0200
commit716a5d78690fbd2a14b07ff514d5798a5c03eab8 (patch)
treef0611698a5e4facd4e3eb645bf0c11bf347eb7e8 /configure.in
parente6007874bd72ba1a5b7ae3672ac47b31cfdccec6 (diff)
downloadgmp-716a5d78690fbd2a14b07ff514d5798a5c03eab8.tar.gz
Pick up x86/darwin.m4.
For X86-32, treat core2 like pentium3.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index be571f5d8..1ed424de5 100644
--- a/configure.in
+++ b/configure.in
@@ -3,8 +3,8 @@ dnl Process this file with autoconf to produce a configure script.
define(GMP_COPYRIGHT,[[
-Copyright 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006
-Free Software Foundation, Inc.
+Copyright 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006,
+2007 Free Software Foundation, Inc.
This file is part of the GNU MP Library.
@@ -847,7 +847,7 @@ case $host in
case $host_cpu in
powerpc740 | powerpc750)
path="powerpc32/750 powerpc32" ;;
- powerpc7400)
+ powerpc7400 | powerpc7410)
path="powerpc32/vmx powerpc32/750 powerpc32" ;;
[powerpc74[45]?])
path="powerpc32/vmx powerpc32" ;;
@@ -1408,7 +1408,7 @@ case $host in
pentiummmx) path="x86/pentium/mmx x86/pentium x86" ;;
i686 | pentiumpro) path="x86/p6 x86" ;;
pentium2) path="x86/p6/mmx x86/p6 x86" ;;
- pentium3) path="x86/p6/p3mmx x86/p6/mmx x86/p6 x86";;
+ pentium3 | core2) path="x86/p6/p3mmx x86/p6/mmx x86/p6 x86";;
[k6[23]]) path="x86/k6/k62mmx x86/k6/mmx x86/k6 x86" ;;
k6) path="x86/k6/mmx x86/k6 x86" ;;
# we don't have any specific 32-bit code for athlon64/opteron, the
@@ -1759,7 +1759,7 @@ if test $found_compiler = yes; then
for flag in $optflags; do
- # ~ respresents a space in an option spec
+ # ~ represents a space in an option spec
flag=`echo "$flag" | tr '~' ' '`
case $flag in
@@ -2990,6 +2990,10 @@ if test "$gmp_asm_syntax_testing" != no; then
case $enable_profiling in
prof | gprof) GMP_ASM_X86_MCOUNT ;;
esac
+ case $host in
+ *-*-darwin*)
+ GMP_INCLUDE_MPN(x86/darwin.m4) ;;
+ esac
;;
64)
GMP_INCLUDE_MPN(x86_64/x86_64-defs.m4)