summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTorbjorn Granlund <tege@gmplib.org>2011-12-01 19:36:30 +0100
committerTorbjorn Granlund <tege@gmplib.org>2011-12-01 19:36:30 +0100
commit4110f3a846acd7eb83002c64cba9858557a8a7c9 (patch)
treea3859a28cf71d12f06bd6cb34caee64eb85b294e /configure.in
parent42ed63ced269bb2124cca33d37faf8f9bb115554 (diff)
downloadgmp-4110f3a846acd7eb83002c64cba9858557a8a7c9.tar.gz
Add GMP_NONSTD_ABI also for fat builds.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 15 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 601d6348f..d96a7870d 100644
--- a/configure.in
+++ b/configure.in
@@ -1929,17 +1929,9 @@ case $host in
if test "$abi" = 64; then
gcc_64_cflags=""
- case $host in
- *-*-mingw* | *-*-cygwin)
- path_64="" # Windows amd64 calling conventions are *different*
- fat_path=""
- ;;
- *)
- extra_functions_64="$extra_functions_64 fat fat_entry"
- path_64="x86_64/fat x86_64"
- fat_path="x86_64 x86_64/fat x86_64/pentium4 x86_64/core2 x86_64/coreinhm x86_64/coreisbr x86_64/atom x86_64/nano"
- ;;
- esac
+ extra_functions_64="$extra_functions_64 fat fat_entry"
+ path_64="x86_64/fat x86_64"
+ fat_path="x86_64 x86_64/fat x86_64/pentium4 x86_64/core2 x86_64/coreinhm x86_64/coreisbr x86_64/atom x86_64/nano"
fi
fat_functions="add_n addmul_1 copyd copyi
@@ -2899,6 +2891,17 @@ DECL_$tmp_fbase (__MPN(${tmp_fbase}_init));" >>fat.h
tmp_file=$srcdir/mpn/$tmp_dir/$tmp_base.$tmp_ext
if test -f $tmp_file; then
+ # If the host uses a non-standard ABI, check if tmp_file supports it
+ #
+ if test -n "$GMP_NONSTD_ABI" && test $tmp_ext != "c"; then
+ abi=[`sed -n 's/^[ ]*ABI_SUPPORT(\(.*\))/\1/p' $tmp_file `]
+ if echo "$abi" | grep -q "\\b${GMP_NONSTD_ABI}\\b"; then
+ true
+ else
+ continue
+ fi
+ fi
+
mpn_objects="$mpn_objects ${tmp_prefix}_$tmp_fn.lo"
mpn_objs_in_libgmp="$mpn_objs_in_libgmp mpn/${tmp_prefix}_$tmp_fn.lo"
@@ -3062,7 +3065,7 @@ for tmp_fn in $gmp_mpn_functions; do
# If the host uses a non-standard ABI, check if tmp_file supports it
#
- if test -n "$GMP_NONSTD_ABI" && test $tmp_dir != generic; then
+ if test -n "$GMP_NONSTD_ABI" && test $tmp_ext != "c"; then
abi=[`sed -n 's/^[ ]*ABI_SUPPORT(\(.*\))/\1/p' $tmp_file `]
if echo "$abi" | grep -q "\\b${GMP_NONSTD_ABI}\\b"; then
true